Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


soapy67

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

  1. I changed the battery on my mk2 2005 16 tdci now when I turn the key nothing doesn't even turn but the immobiliser light flashes frantically any ideas what to do to get it started
  2. . Iam stomped it doesn't back fire or miss the car hasn't missed a beat the 6 month he had it never used oil or water the other day for the first time I don't know if this is connected to it but for split second the cd radio cut out just before it happened do u think a cheap after market cd player we have in it could cause this as it does have a bad earth on it
  3. Had the car 6 month not one bit bother recently been having dreaded limp mode delve ingot po483 cooling fan rationality u1900 can bus (wiring) p1245 wiring alternator p1577 wiring app sensor p1622 immobiliser code incorrect p1386 variable cam timing overbalanced bank 2 p193b accelerator position sensor app. P1936 wiring Cpp sensor could all this be down to a faulty alternator as it used to whistle like it was on its way out and doesn't now since the limp mode happens or cluster panel or ecu or all 3 ? Any help hint anything would be appreciated thanks and merry Xmas and happy new year
  4. changed the fuel filter today on the 1.6tdci mk2 focus because just driving along and it cuts out all the dash lights stay on but when I turn the key nothing I leve it for 5 mins put the key in the door lock then unlock and it starts again and away it goes till it happens again anybody help it's not the fuel filter pleaaaaaaseeeee help anybody
  5. how do I post a querie on the site from an ipad