Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


andy_gib

Budding Enthusiast
  • Content count

    17
  • Joined

  • Last visited

  1. Oil Vanished

    Update: garage have had a look & can't see any leaks. He's suggested the engine may just be "using" the oil or as I suspect burning it. He's changed oil & filter + added some seal conditioner to the oil in an attempt to see if that stops the oil loss. If it continues to drop he will investigate further. If the seal conditioner works isn't that just delaying a possible internal problem? Will see how it goes but thinking of trading it in for something other than a Ford. Thanks for all your replies to the post. Sent from my iPhone using Ford OC mobile app
  2. Oil Vanished

    Thanks for the reply. Cars still losing oil but not loads. Waiting to get Christmas out of the way before I take it to the local garage. Will pass on PVC suggestion when I do. Cheers Sent from my iPhone using Ford OC mobile app
  3. Oil Vanished

    Cheers, Thought it may be thermostat stuck open. It was only replaced about this time last year. Will see if I can replicate problem later this week & give your suggestion a go as temp dropped by nearly half to the quarter mark. I seem to be learning a lot about cars from the problems this ones giving me. Sent from my iPhone using Ford OC mobile app
  4. Oil Vanished

    Update: no smoke when warm or revved to 3/4000 rpm. Oil has being brimmed so will see what happens over the next few weeks. Hopefully get Christmas out of the way. Another odd thing did happen the other night coming back from work. Engine warmed up put heater on full to warm me up and the engine temp dropped significantly. It was cold outside but don't think that suppose to happen? Could the two be linked? Sent from my iPhone using Ford OC mobile app
  5. Oil Vanished

    Cheers, will give it a go at the weekend. Sent from my iPhone using Ford OC mobile app
  6. Decent Wiper Blades

    Cheers. Sent from my iPhone using Ford OC mobile app
  7. Oil Vanished

    05, 65'000 ish. Petrol. Guy I bought the oil from said some engines consume more oil than others. Full to zero, can't be right. Sent from my iPhone using Ford OC mobile app
  8. Oil Vanished

    Haven't noticed any blue smoke on start up. When the engines warm & idling no smoke at all. Would you only get blue smoke on acceleration or also idling? No oil on ground, as far as I can see, engine also looks clean. Sent from my iPhone using Ford OC mobile app
  9. Oil Vanished

    Hi all, got a bit of a surprise last week when I check my oil for the fist time in cough, cough a couple of months. Dam thing was practically empty. Anyone got any ideas as to where it may have gone or things I need to check? 2.0 litre Duretec HE. Do these things eat it? Been fine since I bought it last year. Bit of a concern, No lights on dashboard. Last serviced (full) in April/May time. Oil was probable last checked July/august, can't remember so I guess their wasn't any problem. Refilled with Castrol Magnatec, no idea what the previous make of oil was. Sent from my iPhone using Ford OC mobile app
  10. Decent Wiper Blades

    My wiper blades are also coming to the end of life. Currently Bosch, but thinking of trying Michelin stealth. Anyone have any experience of using them? Better worse than Bosch? Mk2 2L Tit/estate Sent from my iPhone using Ford OC mobile app
  11. Water Leak In The Boot Of My Mk2 Estate

    Had the same problem. Turned out to be small gaps/holes letting in water at the end if the roof rail. Water running down into vents/Believe it's a well documented problem with the Mk2 estate. Stupidly took it to the local ford dealer who charged a small fortune to fix. Initially they just put a little bit of silicon around the joins but leak still persisted. Later took off roof rail & inside trim, sealed from inside & out. Would probs give it ago myself next time if the other side goes. Also check boot hinges & rear light fittings. Sent from my iPhone using Ford OC mobile app
  12. Gears & Other Problems.

    Although biting point seems to still be quite high. Isn't a symptom of clutch failure a low or moving biting point? . Sent from my iPhone using Ford OC mobile app
  13. Gears & Other Problems.

    I think so. Speed doesn't seem to go up as quick as I would have thought. Seems to be on a par with my old 1.5 Honda. Another reason I've convinced myself it going to cost a bit to fix. Sent from my iPhone using Ford OC mobile app
  14. Gears & Other Problems.

    Hi, All. I've been experiencing some intermittent symptoms on my 05 2L petrol Focus over the past few months and I've convinced myself it's going to cost a fortune to fix. I've had difficult engaging 1/2/R gears (occasionally pops out/difficult selecting) When the clutch is engaged (foot off) light thudding can be heard, pressed noise goes away. I feel the cars being sluggish since I bought it, thought a good service would have sorted that out but still seems slower than expected. In the last service (April) local mechanic said gear linkage was tight but managed to free it and get it working better. Would that course symptoms? Replacement part £350 +fitting & vat? Seems a lot to me. I keep reading posts about flywheels/ clutch and I seem to have convinced myself it's going to cost a small fortune to fix = wife's not happy. Taking it in next month (when I've been payed) but just wanted to get some/any opinions before I do. Sent from my iPhone using Ford OC mobile app
  15. Hi, did you ever solve this? As I seem to have the same problem, 2.0l petrol with random rough starts. Need to give it a bit of welly on the gas to get it going, low revs & dies if not. It's got better since a full service a coupe of months ago but probably happens on 10% of start ups. Currently not a big enough problem to start spending money on but it's very annoying. Sent from my iPhone using Ford OC mobile app