Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


angus5041

Budding Enthusiast
  • Content count

    39
  • Joined

  • Last visited

About angus5041

  • Rank
    Settling In Well

Contact Methods

  • First Name
    james

Profile Information

  • Gender*
  • Ford Model
    titanium
  • Ford Year
    2007
  • UK/Ireland Location
    Lancashire
  • Annual Mileage
    0 to 5000

Recent Profile Visitors

707 profile views
  1. Hi Peter, I have double checked visually all around the engine bay no signs of damage/water etc The leads all got changed the same time as the coil pack as well as brand new spark plugs. Is there a throttle body sensor I can replace seen a few on ebay but can't exactly find where about in the engine bay it is? i'm clutching at straws now as I cannot find anything obvious wrong with the wiring etc and surely it cant be the coil pack/leads again. Thanks, Jim
  2. i have not noticed any water about but will be giving a thorough check tomorrow around the harness and battery areas all new leads an plugs a couple of years ago less than 5 or 6 K mileage
  3. Cheers Peter , another coil pack it is then , about 3 years ago i put a Bosch coil pack and ngk spark plugs , about 14 months ago i changed the pack for a non branded one,
  4. Hi, These are the dtc's showing from the laptop, I also run a live test monitoring the throttle voltages and cars rpm which seems to dip to about 600 quite a lot almost causing it to stall as its usually idling around 1000, from the dtcs it looks like coil pack problems again and throttle sensor issue which i've not come across before. Any advice on my next steps please? thanks a lot, Jim
  5. Too hot to have another go , not sure if in demo mode i think it was the real deal. i double clicked as it said and things came in box then died ., :( at least i am having a go . i wouldn't had the confidence without your help .. will try again soon ,,, Sorry yes .plugged in the car
  6. well i got to number 8 .. was going ok then lappy died lol
  7. Sorry forgot to say its a 1.6 focus titanium 07 plate , i have been wanting to change my spoiler for a silver bigger one the how to is brilliant that will be a job i could do
  8. Hi Peter , i think it may have been p303, i new it had a 0 and 3 in it , what put me off was having to download stuff for the elm 327 and when i plugged in the car was terrified of touching anything in case something went wrong
  9. Hi peter, apologies for the reply . could not find it tbh lol ,, i did get my son to use his OBD hand held and it was 2003 i think,pointing to maybe the coil pack or leads , I have changed the coll pack twice in the last three years , once with new leads,, so he turned the EML light off, the next day [thursday] it came back on .. what i meant by "holding it down" was the trip button to reset the mileage to zero as you are aware if you switch on the car whist holding it down it goes into a sweep mode then by pressing it it goes thru other modes which i have no idea what they mean but this turns the light off,. on friday drove from Merseyside to Dundee no problem but the return journey on the sunday the EML came back on minutes later, the reset didnt work this time the car drove fine, stopped at Carlisle for 30 minutes got back in to continue and the EML was out has not been on since ..... i did buy an ELM 327 from this site but was far to complicated for an dinosaur like me Regards Jim
  10. Thats weird something similar happened to me this morning,5 minutes into driving stopping at lights the car just cut out and upon restarting the EML came on,followed by the seat belt warning beeps ,not mine the passenger side ?? and i was alone .. was ok if i held it down but EML still on would that be a cluster problem ,,
  11. Cheers Stoney
  12. Hi all. Came to change the battery on my focus 07 and could not get the thing out ,, there is a metal bar across it i can undo all the nuts but cant move it ,, any help please
  13. sorry to "hijack" your post Jason but am thinking two birds one stone
  14. Hi all same thing happened to me one hour ago on way home fromwork eml came on would not go over 30mph and juddering like mad any help please .. 07 Focus petrol
  15. I have heard that if you do not pay and ignore any "demands" you may receive there is not a lot they can do, the letters you get may look official and scary because this is what these companies want you to believe , go to the website martin lewis has called moneysavingexpert.com do not pay anything