AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Wavey Davey

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About Wavey Davey

  • Rank
    Newbie

Contact Methods

  • First Name David

Profile Information

  • Ford Model Focus Ghia Est 2.0 petrol
  • Ford Year 2005
  • UK/Ireland Location Norfolk
  • Annual Mileage 0 to 5000
  1. Engine Management Light

    Many thanks for the replies . I'll get him to write down the codes when I next see him and I'll post them on blog . In the meantime the light has actually gone out . I usually fill up,at the supermarket purely cos it's near and cheaper but yesterday I filled at a shell garage and today the light has gone out ! I have been told that fuel from the supermarkets isn't as clean and has a habit of causing lights to come on ?? Also been told to fill from a non supermarket garage say every third fill ? Not sure if there's any truth in that but it seems a bit coincidental . Just have to keep driving to see what happens . Would it follow that no light on means nothing would read on a fault finder ? Thanks again
  2. Engine Management Light

    Hi all , ok so what i know about cars , they have four wheels ( five with spare ) and a steering wheel and they get me from a to b !! u get the idea . ive a focus ghia est 2.0 pet ok so i keep getting this light coming on , its the engine block one , to do with the emissions system apparently. my mechanic, who is a damn good bloke, and i consider to b genuine has had the car in a couple of times and changed a couple of sensors after reading the faults on his , fault reader ? , and repaired a split rubber pipe but each time the light comes back on after a couple of trips. i dont use it much mainly weekends and it doesnt go far . but its annoying! he says it shows more than one fault so were starting with the cheapest bits to replace before thinking about cat converters and stuff. im sure im not the only one so has anyone got any suggestions on causes ? or what theyve had to do. the car seems to run fine but dont like driving it around with light on much , as im sure its on for a reason. Thanks in advance for any replies. Happy motoring.