AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Boban32

Budding Enthusiast
  • Content count

    8
  • Joined

  • Last visited

About Boban32

  • Rank
    Newbie

Contact Methods

  • First Name Bogdan

Profile Information

  • Ford Model Mondeo mk4
  • Ford Year 2008
  • UK/Ireland Location Herefordshire
  • Annual Mileage 10,001 to 15,000
  1. Mondeo Mk4 Starts Vibrating At 60Mph

    Indeed,there seems to be some movement in the driveshaft I have replaced, the mecanis said. Had successfully done my trip, and the shake seems to get worse. I ll change the driveshaft and let you know Thanks everyone for your help
  2. Mondeo Mk4 Starts Vibrating At 60Mph

    Well the vibration seems to be worst at 60 when accelerating, and it slowly dies away at around 90mph, at 100mph it s perfectly smooth. However if I accelerate constantly, eg cruise control, most of the time it does it at any high speed
  3. Mondeo Mk4 Starts Vibrating At 60Mph

    The mechanics I have seen excluded the DMF as they said that it usually makes a banging noise when the engine is idling
  4. Mondeo Mk4 Starts Vibrating At 60Mph

    Cheers silly me
  5. Mondeo Mk4 Starts Vibrating At 60Mph

    And what exactly is the DMF??
  6. Mondeo Mk4 Starts Vibrating At 60Mph

    The tires are new, and when the shake happens if I press the clutch the car goes smooth which in my mind removes the wheels from the discussion, and also it does it regardless of the gear it is in
  7. Mondeo Mk4 Starts Vibrating At 60Mph

    Yes the wheel balancing has been checked and there fine, as for the engine mounts do you think there could be the two top mounts as i allready changed the bottom back one. Allso the shake does not come through the stering wheel, I feel it througr the accelaration pedal and the seat underneath me. I allso changed an off side drive shaft some 6 months ago as the car was making some strange noise when starting to drive, do you think it could be from there? One of the driveshafts?
  8. Hi, it s regarding a funny shake the car starts to have at around 60mph while accelerating. Had a few mecanics looking at it but no one seems to know what it is. I had the wheels checked and all the bushes seem to be fine.one of the mecanics got me to change some stabiliser bush on the engine but that did not solve it. The car has about 185000 miles and i m pretty sure it has the original clutch kit, but it seems to work fine. Please help as i allso need to drive the car back to the uk, about 1600 miles