tomtom16

Budding Enthusiast
  • Content count

    41
  • Joined

  • Last visited

About tomtom16

  • Rank
    Settling In Well

Contact Methods

  • First Name
    tom

Profile Information

  • Gender*
    Male
  • Ford Model
    focus 1.6 zetec
  • Ford Year
    2003
  • UK/Ireland Location
    Yorkshire
  • Annual Mileage
    5001 to 10,000
  • Interests
    General Automotive
    Motorsport & Racing
  1. i need some semi urgent help with a friends 07 plate ford focus. recently when he turns the key off the engine stays running, he had to reinsert the key and turn it off and on to get the engine to switch off. also he accidental pressed the brake pedal when getting out and all the dash lights came on and stayed on until he used the key to turn it off and on again. the last bit of information i have is when he was driving and braked the dash light for the headlights and i quote the one next to it came on. i think its a bad earth or a crossed wire but i know nothing about these sort of things. any help to narrow down the problem would be greatly appreciated. thanks
  2. would egr valve cleaner clean the idle control valve without damaging it? thanks for any replies.
  3. anyone would like to know the best thing to clean it with was going to use egr valve cleaner on everything
  4. Hi I was wondering where the egr valve is located on my car. i have a rough idle and am looking at cleaning the egr valve and idle sensor tomorrow when i change my manifold but I cant find any information about the egr valve on my car. makes me wonder if i even have one. sorry for sounding stupid, any help is appreciated thanks
  5. the strut on the passenger side as been changed i forgot to mention that in my original post. i am going to have a look next weekend and see what i can get to move underneath but it still bugs me how it was fine for a few days and then it came back. thanks for the reply
  6. hi, i have recently had the subframe changed due to being told it was twisted. Before i had it changed the only sign of a problem was a tracking off type feeling. and some quite severe knocking. when i had the subframe fitting I also had new drop links and anti roll bar bushes fitted.it as also recently had a lower arm fitted. Now to my problem, the knocking is still there, it seemed to be loads better for a few days and then seemed to start again. It never fully went it was still there on some bumps and when turning left. what else could it be? everything looks ok underneath and the mechanic that fitted the subframe said all seems fine too. I am thinking possible cv joints but the fact it seemed to be better and then come back it confusing me to be honest lol I think the knocking is coming from the front passenger side. i should point out that before i purchased the car it was in some sort of accident and other than the front cross member being bent and sending all the passenger side panels out of alignment everything as now been checked and/or replaced sorry for the confusing post lol thanks for any help
  7. hi guys, just wondering if i need to remove the drive shaft to change the strut or can it be moved enough to get the strut out and a new one in??? front passenger side mk1.5 focus
  8. i'm going to try and change the strut in the morning and see how it looks after i have aligned it best by i can by eye. A full alignment check is going to have to wait till pay day. As i said i have had it looked at by a professional body shop, not on an alignment machine. But the guy said he has seen it loads of times and was almost sure it was the leg. if i can get it close then it will be better till i can get it fully repaired and aligned. quick question do i need to take off the drive shaft to or can i move the hub enough to change the strut??
  9. someone has half repaired the car already its had a wishbone already can tell its newer, track rod looks newer too. I think its been half repaired. The subframe is out of alignment a body shop reckons its just been moved and the leg is bent. The hub looks ok. i should mention that it is stiffer on that side. most of it look fine by eye. the wheel is straight just about an inch towards the back of the car. Cant afford for a professional to repair so going to have to try it myself. just wondering if you all think that sound like the guy in the body shop could be right. should point out i bought the car like this unknown to me. so i don't know exactly what happened from the little signs that are there i think it was something small could have been a kerb, something no bigger that the bottom of the bumper and not hard enough to even total the radiator, it has got signs of accident damage though.
  10. The only thing i can suggest to try and find exactly where that noise is coming from open the bonnet and just have a listen. sorry i could help, it might still be your belt, i'm guessing its high mileage with it being ex fleet. Try a service and belt change n see if that helps. if that noise is coming from the engine in anyway though i would have it looked at could be a bearing or something inside the engine. get it checked first because if its bad no point servicing etc.
  11. sorry i ment to ask what your getting on your mileage. that's what happens when i keep thinking its the same problem lol
  12. well i'm not sure. with mine if i put just a few 100 revs it stops. could it possibly be just something loose and your fuel something else?
  13. well mine is petrel, as far as the lights go i think its just the battery struggling, its over 10 years old lol its doing well tbh. do your revs change when it happens?
  14. i have got what i think is the same thing. i personally wouldn't call my noise a tapping just like when you lift clutch to far and it wants to stall. i think im getting poor mileage as well about 160 mile to 3 quarters of a tank. i also got told its a vacuum hose. i have recently serviced the car all filters but the fuel filter and it didn't change the problem(i got told it might be a slight misfire). Do your light flicker when this happens?? they do for me but i also still have the original battery and am changing it this weekend. I don't know if any of this helps you but if it is the same as my problem i got told its the vacuum hose by someone who genuinely know a lot about cars. just thought i would try and narrow it down for you.
  15. cheers not even sure where the maf sensor is tbh lol only had the car a few weeks just got a bad idle at the moment.