AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Moz6689

Budding Enthusiast
  • Content count

    15
  • Joined

  • Last visited

About Moz6689

  • Rank
    Member

Contact Methods

  • First Name
    Mo

Profile Information

  • Ford Model
    Fiesta
  • Ford Year
    2009
  • UK/Ireland Location
    London
  • Annual Mileage
    20,001 to 25,000
  1. So result was egr valve blocked and fuel filter blocked! Had both of these replaced at a cost of approx £450 parts & labour. The car seems to be running good now but given the nature of other ppls issues il give it a week before I'm convinced. The whining noise is still there though as I accelerate. Mechanic said this was the turbo pipes when there is an air leak but he checked all my pipes and none are split so I was told to give it a couple of weeks. Work was done by a family run garage; Jackson's Ford specialist in Teddington, great service and quick turnaround. Would recommend them if there anywhere near anyone!
  2. Will post results tomorrow. Thanks again for your help!
  3. Yea checked all hoses and no signs of oil. Performance is fine until the light comes on and puts the car into limp mode. Does a manual have a gearbox module that can be scanned?
  4. I hope it's not the turbo, it starts at about 2000 rpm and gets louder the higher I go but only when in gear. And this is causing the warning light to come on because if I stay under 1500 rpm in every gear it won't come on
  5. Not 100% sure but it sounds like just behind the dash on drivers side, thought it may be something to do with transmission as this is what the powertrain light is for
  6. Thanks mate, I've got it booked in tomorrow with a ford specialist for diagnostics. Would this PCM upgrade stop a whining noise though?
  7. Had a mate do it at work so not quite sure what diagnostics he did. But iv also had the RAC come out and they used there machine on it (not great) no codes. Also had a wireless obd reader which connects to the laptop and gives u a ton of information but again no fault.
  8. I've had this problem for a few days now. The powertrain warning lamp comes on puts the car into limp mode and eventually cuts out. When the car is restarted the lamp goes away but comes back on eventually and it's happening more and more frequently. I've had 4 different code readers attached to it and none have come up with a fault code other than egr sensor which I've been told shouldn't cause this problem. Today (3rd day since it starts) the car has now started making a whining when driving in gear above 2000 revs, im the whining will get louder the higher up the revs I get and the warning lamp comes on more a less 2-3 seconds after the whining starts. Please tell me if you have experienced this problem or know what it maybe as it is driving me mad!!!!
  9. Hi just wanted to find out if the problem ever went away? I have exactly the same problem on my 2009 fiesta and its driving me mad!! Do u know what update ford did to the car?
  10. Ok so i tried the test mode the das and it comes up with er0121 anyone have ny idea on what this is? Search edge but there's just ppl with the same issue no solution
  11. Hi I have a 2009 ford fiesta on a 58 plate. The power train light has come on this evening. The first time it happened I didn't notice an issue, parked the car turned it off. When I came back and started it again the warning light had gone but I noticed when I accelerate hard this causes the power train light to come on, once it's on the car goes into limp mode and eventually just cuts out! Today the car cut out 5 times on the way to work. When it cuts out it comes up with the battery light and if I accelerate in gear then the car pulls back, exactly like if your trying to jump start it. It won't start until I've turned the ignition off completely then back on. Iv connected 3 error code machines to it and all say no errors, but I didn't think this would work as its not an ecu problem. Any idea on what the issue could be & aprox cost of repair?
  12. No plugged in 3 different code readers now and all of them say no error codes. I assume this is because the ecu light isn't actually on, but how do I then go about finding out what is wrong? Today it has cut out 5 times after that light comes on and feels very sluggish even when it is not on. When it cuts out and I accelerate it feels like I am pushing the brakes (literally feels like jump starting a car.) Iv seen somewhere someone mention that this could be the electronic throttle body sensor, that kind of makes sense to me in my head but I'm not a mechanic and don't have lot of knowledge mechanically
  13. Hi I have a 2009 ford fiesta on a 58 plate. The power train light has come on this evening. The first time it happened I didn't notice an issue, parked the car turned it off. When I came back and started it again the warning light had gone but I noticed when revving upto 3/4000 this causes the power train light to come on, once it's on if I go anywhere near 3000 revs the car cuts out immediately. Any idea on what the issue could be & aprox cost of repair?