Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About weejoe

  • Rank

Profile Information

  • Ford Model
    Focus 1.8 Zetec
  1. HI I recently had to replace the spring and top mount on my 1.8 at the front and now there appears to be a knocking noise coming from the rear of the car. I have tried opening the boot and pressing down on rear of car while a friend looked underneath and at the rear wheel to see if anything was loose or anything but nothing appears to be loose. I have recently had to replace one of the roll bar mounts for the mot. Could it be the other one deteriated due to the salt,snow etc or could it be anything else causing the problem. Any help would be appreciated.
  2. Would it be the same size socket required for the Focus mk1?
  3. Hi I am planning on changing the spark plugs on my 1.8i mk1 focus. I am wondering if it will be a 14mm socket to remove and refit the plugs? Cheeers J
  4. Hi I have a leak on both power steering pipes on the rack return pipe and the high pressure pipe. I am wondering if any1 knows the sizes of these pipes, as I have priced them from Ford and they are quite expensive and was considering contacting a hydraulics specialist.
  5. Im wondering how long it would take to change a steering rack on a mk1 focus
  6. HI I have had my 00 V Focus 1.8 Zetec for almost 2months and theres been something wrong every 5 mins. I posted earlier with a power steering leak i think this is now the least of my problems with the car. I checked the fluids after going for a run to notice murky stuff on top of the coolant in the reservoir. And there was also a slight bubling. I checked the oil cap and there's no milky residue. Also checked dipstick which also appears ok.And stopped the car for bout 20 mins. I wouldnt say the reservoir was over pressurised. It wasnt trying to fly through the cap. Like it would if there was a leak of exhaust gases. I also smelt inside the reservoir the was no smell of exhaust gases being used to checking for this having previously owned a Rover 214. It didnt smell like oil either. Ive been just out checking the car over again. There's not any coolant loss. I did however notice that there is a hose from the reservoir to the air conditioner. Is there any oil or anything that could be getting from the air conditioner to the coolant? There doesnt appear to be any running problems or abnormal smoke from the exhaust. I hope this is not hgf!!! Any help would be great before i go anoying my local mechanic lol!!
  7. HI I have a steering leak. Im wondering if anyone can give me an idea where to check for the leak. Ive had a quick look at the hose from the reservoir to the pump and i dont really see any signs of fluid? Is there anywhere is should be looking as ive also noticed that there appears to be a burning smell as well after coming to a standstill occasionally this may have nothing to do with the leak but thought wud mention it!!!
  8. dont think its that coz it keeps on doing it, the only reason i top it up is after a few days it starts making groaning sounds and toppin up the fluid stops it then it goes down to between min and max again :-(
  9. HI I have now replaced lower arm car is now handling a lot better. But steering leak is still there when i top it up as soon as i go for a run it drops to between min and max but never below this. I have checked the hose from the reservoir but there is no obvious signs of leaks and looked again but no signs of anything dripping down.
  10. I am currently waiting for a lower arm to arrive. The strangest thing is that if the fluid is topped up to max as soon as car is started it will drop down to halfway between min and max, And then after a few days the noise starts again. Top fluid up noise disapears for a few days. Hope its nuffing serious!!!
  11. Been out checked power steering fluid. It was between min - max. Topped it up noise has dissapeared now. But went for a five minute run. And checked fluid again. It has gone back to being between min - max. There was no obvious signs of leaks or anything. Could it be down to the problem with the lower arm?
  12. it sounds like its related to the powersteering although when bonnet is lifted it sounds like its coming from belt area. Nothing was replaced i had the ball joint to fit to the arm that was on it but found the bushes has also gone in the arm therefore old arm was put back on. When turning when moving from standstill or turn the wheel when stationary its as if its putting strain on the pump. Powersteering fluid is between min and max now was up above the max last week. Will top this up later today and see if it goes away or helps any.
  13. I put my car in garage to have the bottom ball joint replaced. To be told the arm needs replacing, since the car came out the garage ive now got a high pich noise on idle it appears to be coming from the belt area. And it appears to have more vibrations through the steering wheel than it did before. It still has the old arm on it but im just wondering what the noise could be!!!
  14. I did the cluster test by holding the reset button and starting the car. It read none for DTC codes. But spose it could be the start of a cluster issue. But I hope not.
  15. Im not sure. All i know is its intermittent. it happened again today! When it happens its actually both the rev count and speedo that go round. I checked the speedo trick which showed no DTC errors. No sure if it could be the battery although when it happens the car doesnt start first time.