AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Urbie

Budding Enthusiast
  • Content count

    10
  • Joined

  • Last visited

About Urbie

  • Rank
    Member
  • Birthday 10/18/1969

Contact Methods

  • First Name
    Urbie

Profile Information

  • Gender*
    Male
  • Ford Model
    2011 Mondeo Titanium X 2.2 163hp
  • Ford Year
    2011
  • UK/Ireland Location
    Other/NonUK
  • Annual Mileage
    15,001 to 20,000
  1. Just out of curiosity I wanted to find the bluetooth module to reset it. However I could not find it. But I was thinking that if it is connected to the stereo system maybe it gets its power from the stereo, so I pulled the fuse (43) in the engine bay, waited 5 minutes (played a bit of solitaire) put the fuse back in and guess what? After putting in the code everything started worked. Bluetooth and USB. So Ford was just spinning me a bit of crap. I am disappointed...
  2. Indeed the warranty just expired last month. I actually told the dealer that it was ironic that 1 month after the warranty expired this happened. Oh well never mind. I will have to do without it until next month, with Christmas I have other important expenses. Until then I will just have to pull over to answer the phone...
  3. Update. Went to my Ford dealer and he says the bluetooth module needs to be replaced. And will cost About 400€ to replace including labour and vat Oh well
  4. Hello everyone, I am not a mechanic or an auto elec so please be gentle. I have had my 2011 Mondeo Titanium X for 1 year now and I have had no problems what so ever. Suddenly today I wanted to use my phone and when I pressed the phone button it muted the radio. Also the USB where I have my iPod plugged in doesn't work either. Can someone help Please Urbie
  5. I am actually talking about the electric windscreen heating...
  6. Hi all I have a 2005 Focus Ghia, I have a small problem not that it really bothers me because its on the passanger side but the missus is giving me a hard time about it. my front windscreen heater doesn't work on the passanger side. There is a perfect line down the middle where the heating works and not. My question is, is it as simple as changing a fuse to fix the problem or should I go to an auto elec to have a look? Thanks
  7. I have a 2005 focus ghia 5 door with 4 power windows and it works for me. I press and hold the open or close botton on my remote control and all the doors open or close
  8. Thanks guys for the post. I appologise for not replying sooner but I had computer problems too.... Theproblem was solved the next day. Thanks again
  9. I have a 2005 focus ghia and I have my Ipod headphone jack connected to the AUX jack in the glovebox
  10. Hi I recently had an altenator replaced on my 2005 focus ghia. Before I had the problem I was able to push down on the window button and it went all the way down, then pull up and it came all the way up itself. Now, since I had the altenator replaced only the drivers window works like this, the others do no come up by them self. Could this be a simple reset issue. If so can someone tell me if this can be done or do I have to a dealer.