AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


HannaHexagon

Budding Enthusiast
  • Content count

    15
  • Joined

  • Last visited

About HannaHexagon

  • Rank
    Member
  • Birthday November 7

Contact Methods

  • First Name
    Hanna

Profile Information

  • Gender*
    Female
  • Ford Model
    Focus
  • Ford Year
    2005
  • UK/Ireland Location
    Gwynedd
  • Annual Mileage
    5001 to 10,000
  • Interests
    General Automotive
    Travel
    Road Trips
    Food & Drink
    Entertainment
    Health & Beauty
  1. Welcome to the forum, Joe :)
  2. Hi James, I've got it sorted today thanks! :) I'll have a read quickly though, OBD and codes tend to interest me for some reason! It turned out there was a leak... but in the thermostat holder, spewing out water! One of the bearings had gone on the cambelt pulley too which was triggering the warning lights. So, waterpump, cambelt and oil change, new thermostat holder and a quick look over. Not as bad as I'd expected! Thank you everyone.
  3. I'm very sure it's not that. The one you're on about is red, and on the right side of the dials. The warning light that came up on mine was yellow and on the left, right above the 'check engine' warning light. I'm quite convinced it's this.
  4. I was going to get it serviced next weekend actually, as it had been just over 6k since the last one. I had it booked in weeks ago. Thanks though.
  5. Why, oh why do I not have breakdown cover? :(

  6. I was told by a ford mechanic months ago that it goes either milky when it mixes with water or brown when it's used. Is this not correct?
  7. Oh, right! Silly me. Only a few minuets, literally a mile. I haven't checked the coolant, that's a good point. I'll have to moider the mechanic tomorrow about the oil! Thanks :)
  8. Oh, that was my old car. Not this one! The oil is fine in it, still black. I checked that last night too!
  9. The fan is working fine, I can hear it's usual buzzing when the engine is on. I was sort of thinking it might be something to do with the radiator... My old car had major issues and the radiator was leaking coolant. Unfortunately, I didn't know until the head gasket blew and everything else soon followed! Hopefully this won't happen again :( Expensive job. Thanks! It makes sense. I haven't been able to get hold of a garage or mechanic that's available today as it's Sunday :/ I'll have to wait until tomorrow.
  10. I'm Hanna, and I'm from Caernarfon.
  11. Hi all, I'm a newbie to the club! I'm Hanna, and I'm from North Wales. I bought a 2005 focus 1.6 LX in August and I love it! Anybody any good with the MK1 models? I have a few questions!
  12. Over two years. I promise I wasn't hammering it! :P
  13. I have a 2005 Mk 1 focus hatchback with just 58k on the clock. It's been an absolute dream... until today. The Engine light and a light with an exclamation mark (warning light?) came on, and the temperature gauge went straight into the red. The car then acted as if it was about to stall, jerking and making weird noises. I had to leave it in a local car park as it's completely unmovable and I don't have breakdown cover :'( What do you guys reckon is wrong with it? There is plenty of water in the tank and there doesn't seem to be any leaks. (I check the car quite regularly) To my knowledge, the oil in the car is still black. I heard that these focus' need the water pump changed at the same time as the cambelt, is this true? Is it the water pump that's gone? Thanks in advance guys and gals.