AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


linc100

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About linc100

  • Rank
    Newbie

Contact Methods

  • First Name peter

Profile Information

  • Ford Model mondeo tdci mk3
  • Ford Year 2007
  • UK/Ireland Location Lincolnshire
  • Annual Mileage 15,001 to 20,000
  1. Hi all thanks for your comments on my car problem, but its been to diesel company who did diagnostics on it, like they do and I guess investigated it further as well, but found no problem, but said it could be injectors, but not sure, I've got excellent fuel consumption late 50s early 60s and its got full service with only 60k on the clock with no problems till now, done the turn screen heaters on like someone said still same, turned air con on still same, turbo works fine ,well it still accelerates well on the motorway, starts 1st time with no smoke from exhaust, and runs smooth over about 30mph,under that its abit jerky, and at idle revs drop and you notice something not right, read about tensioners on sites but surly this wont result in the jerkiness and idle drop,or trying to drop like hunting ,and if it was an injector problem, I would lose fuel, have exhaust smoke of any colour, and start problems, its gone on now since last sept,and got slowly worse but still keeps going ok,but to sell it I really want it sorting as I don't want to sell a bad car to anyone, not my nature. had the codes done and the egr blanked of, cleaned the maff sensor as recommended but now im at a loss guys, could it be something simple,i would do leak of test if I thought it was a injector,,get no fuel smell either, so combined im hoping for any help you members can give me, oh ive had nothing repaced engine wise on the car other than the usual service items,
  2. Hi all, I came bouncing on here without even introducing myself, I live in Lincoln and yes its near Skegness as people always say ,as I work all around the country as an aerospace fitter,and to some Lincolns an alien place not on the map, I own a ford mondeo tdci mk3 115 edge,07 plate which I bought 2yrs ago with 22000 on the clock, which is very good,with full stamped history and docs. Its been a good car giving me late 50s to mid 60s fuel economy which I really never expected,ive read a lot of bad reviews on the problems, with this engine but up till now I cannot fault my work horse of a car, But im going on other forums now to put my updated info on as to my problem, with my workhorse,please find me and give me any constructive advice as between you guys and girls your problems and knowledge combined is a powerful tool, linc100
  3. I have a mk3 mondeo tdci mk3 2.0 with full service and 60k miles,the engine has got louder at idle,its been gradual but now noticeable,its a bit jerky on accelerationfrom stand still and the engine hesitates at at idle,it has been to a diesel specialist, who found no faults,ie codes,and would not rule out injectors,but not certain.it starts 1st time and has no smoke from the exhaust,i get around 55 to 60 miles to the gallon,but in a nutshell it sounds and feels rough,i blanked of the egr cleaned the maff sensor, changed the fuel filter, of which the specialist checked and found no debris. now the little engine symbol on the dash has come on and stays on, ive used a rac code reader now and 0001 and 0002 show up, which if I remember was fuel pressure regulator/fuel pressure valve open. not sure if that helps or could make my engine loud and run bad, my big fear is the injectors. if you guys can give any pointers I would be a grateful man