Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


copelcon91

Budding Enthusiast
  • Content count

    15
  • Joined

  • Last visited

  1. Yeah I mean I have a massive reel of the wire so not relaly worried about that I jist didnt wanna hack into any ignition lives? Wanted the easiest and safest separate way to do it thanks for replying really appreciate it Sent from my GT-I9505 using Ford OC mobile app
  2. Would you send the link to join please? Sent from my GT-I9505 using Ford OC mobile app
  3. Hiya just wondering where i can get the owners club sticker from? Thanks Sent from my GT-I9505 using Ford OC mobile app
  4. Evening everyone! Am after some safety check advice, have got a drl kit to fit to my mk2 ford focus im going to run the wire threw the grommet on the bulk head to a switch in my glove box then to the battery to the lights with a fuse in the wiring does this sound the safe way to do it? I want the lights on a switch so there at my control! Thanks very much Sent from my GT-I9505 using Ford OC mobile app
  5. Haha you laugh but I got asked if I had done that!!! The cheek well good luck getting it fixed! Be interested to see what they do to rectify it! Sent from my GT-I9505 using Ford OC mobile app
  6. Hiya mate!! I had this issue countless times! Everyone I took it to said about the core plugs so I had them replaced but yet water was still finding its way in the cylinder head and the core plugs and coolant wasnt leaking! After a while I investigated the issue myself and found the bonet where the washer jets sit leak water when it rains like you would not belive! So I sealed them up and they still leaked. I then thought about an engine cover I rang ford and it is not something they make! So with no luck I made my own out of perspex and covered the ht lead top and touch wood to this date theres not been a drop of water in there and it hasnt ever misfired! It looks daft but I dont care it runs perfect! Hope you get it sorted Sent from my GT-I9505 using Ford OC mobile app
  7. Seems to be repaired! Fingers crossed aparently ford focus zetec have a gap for sparks of 1mm not 1.3 1.3 can cause the intermittent missing cheers for everyones help! Sent from my GT-I9505 using Ford OC mobile app
  8. Have had genuine parts fitted and the csrs been pressure tested when the core plugs was at fault and that didnt bring a y ither issues up but not sure if its because of the tiny ammou t of damp in cylinder 4? Sent from my GT-I9505 using Ford OC mobile app
  9. Yeah its got new ht leads new sparks new coil pack to just seems strange If its throttle why only 3rd? Could it be the spark plugs gap being incorrect Sent from my GT-I9505 using Ford OC mobile app
  10. When you say hole do you mean at the top where the spark plugs into ? On top? Sent from my GT-I9505 using Ford OC mobile app
  11. Yeah well that's what I have to but I have got 98% out but hole 4 still has a slight amount there? Possible cause? I had this from leaky core plugs Sent from my GT-I9505 using Ford OC mobile app
  12. And only in 3rd gear high gears at high speed is fine its around 25mph in 3rd that it does it Sent from my GT-I9505 using Ford OC mobile app
  13. No codes was present was only the garage saying its a misfire after them test driving the car the misfire is not as severe but there a little only one little judder every time you hit the throttle hard Sent from my GT-I9505 using Ford OC mobile app
  14. Hi not 100% on spark plug code but its had both bosh and now has mgk ones in Sent from my GT-I9505 using Ford OC mobile app
  15. Hi all I have an issue with my 2005 1.6 zetec focus. Basically it developed a misfire whi h turned out to be from the core plugs leaking I have had them replaced and new sparks it kept misfiring after that the garage then replaced the ht leads and coil packs and another set of sparks setting the gap to 1.3mm is that right? But it is still misfiring im 3rd gear usually when I have taken a corner then I put full throttle on and the car jumps but only a couple of times and nothing to extreme as when it first had the misfire issue.... any ideas what the problem is? The spark plug gap incorrect? ? Thanks in advanced