NSIngram

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

  1. Hi there, I'm new to this sort of thing but had no option to come here for some advice! My car is a 2008 Focus Mk2.5 1.6 Zetec (petrol) (67,000 miles) and for the past few months it's had terrible starting issues that aren't exactly consistent. I turn on the ignition and go to start and it will turn over fine with a few coughs (trying to fire) and averagely starting after about 5/6 starts. (As I said it's not consistent as this morning it started 2nd try). Sometimes I will have a message pop up whilst I'm trying to start which is either; 'ESP off', 'Aux Heater 0%'. Also, when eventually started, (I'm not sure of this is connected to the situation) it splutters slightly for maybe like 1/4 mile down the road, with slight loss of power. In the afternoon it starts up first time (usually) so it's normally first thing in the morning. Hopefully one of you guys can point me in the right direction, thanks in advance! (Edit) The truth is I probably created an account many years ago and completely forgot! 😂
  2. Cheers for your feedback guys, still not 100% but I can always try them when I've bought it :)
  3. In a few months I will be purchasing a Mk7 Fiesta ST. I'm looking forward to it so much I've started looking at new wheels. I'm not sure wether to keep them stock or fit these. They are Fifteen52 - Tarmacs. Could I have some of your opinions, I can't decide. Thanks :D (I photoshopped these myself.)