Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About DeanoFiesto

  • Rank

Contact Methods

  • First Name

Profile Information

  • Gender*
  • Ford Model
    Ford Fiesta Zetec S
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    5001 to 10,000
  1. I recognise that dealership, tis also my local ford dealer as well! Great team in there. Welcome to the Fiesta Club!
  2. Thank you for info tho. As its still got some warranty left, probably worth getting it looked at!
  3. I think its mostly at any time, not just turning. Handy info, thanks mate!
  4. Its mostly on and off, sometimes it'll make it and sometimes it will be quiet when driving. Its a 2011 with 27k miles, so I'm guessing the they are still the original discs? Had a MOT and Service back in August 2013
  5. Yeah, mine does sound more metal sounding, but its difficult to describe.
  6. Hello all, Hope you can help me. Over the past few weeks, a on and off squeaking noise has started coming from the front of the car. From a rough guess it sounds like its coming from the front passenger side. Its not loud but is noticeable. Anyone have an ideas on whats causing it? Cheers
  7. Cheers Lenny, will take a look! Sent from my iPhone using Ford OC
  8. Ah nice one, yeah the map reading light is probably the most missed part in my opinion aha! Are there many that come up on eBay? A quick search didn't show any for me... Unless i'm looking in the wrong places? Nice one, thanks Lenny!
  9. Hello, am I bit of a lurker using all the helpful guides over the past few years but have finally appeared! I've recently upgraded from a 2010 1.25 Zetec to a 2011 Zetec S and am missing one thing I have never really appreciated and that's my interior lighting! My questions... I have the standard 'Dome' light... Is there a way of buying and fitting the Map reading lights (Submarine) in my Zetec S? (Not sure where you would buy them) Secondly, is it difficult to retro fit the LED strip above the glove box? Cheers!
  10. Thank you for your replies! The boot release button has also decided to die, so I believe its probably something to do with the boot mechanism. Will mention it with my service which is due next month, sadly car is out of warranty by a year.
  11. Hello guys, hope you can help... Since November, my boot has been randomly opening every so often. I disconnected the battery to reset and all was well for about 2 weeks. Now the car is doing it every trip and sometimes I can't get into the car quick enough to lock the car from the inside to prevent the boot from opening! Any suggestions?