AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


sparkplug1988

Budding Enthusiast
  • Content count

    24
  • Joined

  • Last visited

About sparkplug1988

  • Rank
    Member

Contact Methods

  • First Name tony

Profile Information

  • Ford Model mondeo mk3 zetec s 2.0 tdci estate
  • Ford Year 2002
  • UK/Ireland Location Kent
  • Annual Mileage 15,001 to 20,000
  1. Alloys Refurb

    Thank you for the in depth information. Did you do it with the tyre on Sent from my C1905 using Ford OC mobile app
  2. Alloys Refurb

    Thinking about refurbing my alloys as they have seen better days. Have anyone refurbed there own. What's the best kit to use and how easy is it to do. Many thanks. Sent from my C1905 using Ford OC mobile app
  3. Nasty Noise Coming From Aux Belt

    Where can I get a gates tensioner Sent from my C1905 using Ford OC mobile app
  4. Nasty Noise Coming From Aux Belt

    It might be worth getting a new tensioner from gates then. Can't see it being the New crankshaft pulley I put on as there is no play on the crankshaft pulley. It a poor design. It's embarrassing noise. Thank you for the information Sent from my C1905 using Ford OC mobile app
  5. Nasty Noise Coming From Aux Belt

    Hi all. I've had a nasty rumble a while back and I changed the tensioner and crankshaft pulley and that cured the noise. How ever it's come back. So I changes the aircon pump and still the same what else can it be. The new tensioner I put on a while hack is bouncing. So would it be a dodgy tensioner I bought. Has anyone else had this problem. Cheers Sent from my C1905 using Ford OC mobile app
  6. Mondeo Rumble. 2.0 Tdci Mk3

    It seems to be worse when the aircon compressor kicks in. I wonder if it's the The clutch in the pulley that's playing up Sent from my C1905 using Ford OC mobile app
  7. Mondeo Rumble. 2.0 Tdci Mk3

    Hi all. I had a nasty rumbling noise a while back so I changed my belt and tensioner aswell as my crankshaft pulley and the noised stopped. But recently the noise came back. And ideas. It's not a main bearing. Or big ends that's a certainty. Any help would be grateful. Sent from my C1905 using Ford OC mobile app
  8. Power Steering Pump Suspect

    That's what I thought but atm it seems ok so hey ho my motor fixes it's self haha thanks lads for the replies Sent from my C1905 using Ford OC mobile app
  9. Power Steering Pump Suspect

    Thank you for your help tho. Might just get a new pump and have it on standby just in case Sent from my C1905 using Ford OC mobile app
  10. Power Steering Pump Suspect

    Very strange only thing I can think of is a blockage or the pump is slowly given up Sent from my C1905 using Ford OC mobile app
  11. Power Steering Pump Suspect

    It seems to have stopped making the noise and the fluid had remained at the max line. Well and truly stumped me Sent from my C1905 using Ford OC mobile app
  12. Power Steering Pump Suspect

    Mind you I did fill the fluid up about 2 week's ago as it dropped below the max and accidentally went over the max Mark but surely that would of bubbled up straight after I filled it up Sent from my C1905 using Ford OC mobile app
  13. Power Steering Pump Suspect

    I put the cap back on and went lock to lock a few times and the noise stopped and the fluid remained at max line Sent from my C1905 using Ford OC mobile app
  14. Power Steering Pump Suspect

    Bubbling up over the max line and out the cap. I haven't done anything that's involves any of the steering rack or pump Sent from my C1905 using Ford OC mobile app
  15. Power Steering Pump Suspect

    Hi the're wonder if anyone else has ever had power steering fluid bubbling out of the power steering cap. I noticed a noise this morning when I turned the steering wheel and when I opened the bonnet fluid was bubbling up from the cap. I undone the cap and turn the wheel lock to lock and the noise stopped and the fluid did not overflow. I'm pretty sure it's not a steering rack. Or was it just air in the system. Any help would be grateful. Thanks for looking Sent from my C1905 using For