AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


honorfenton12

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About honorfenton12

  • Rank
    Newbie

Contact Methods

  • First Name
    Honor

Profile Information

  • Ford Model
    Fiesta Zetec Climate
  • Ford Year
    2006
  • UK/Ireland Location
    Cumbria
  • Annual Mileage
    50,001 upwards
  1. Thank you, I will try a whole new clutch. I now have the engine warning light on in my car it flashed a few time and now it's permanently on. I pulled a computer device in and it gave me a code P0304 spark plugs? Is this common?
  2. I bought my fiesta zetec climate 1.4 back in march 2013. Was a great reliable car for 5 months. However I was driving home on the motorway and noticed when I was slowing down through my gears that it was hard to change 5th to 4th. I thought nothing of it, shortly after arriving home I had to nip out. My car seemed hard to change gear. My dad then bled my clutch and it was back to normal - for 3 weeks. After the 3 weeks had ended the problem reoccurred, again my dad bled the clutch and it was fine again for up to 14-20 days. However the problem then began to get worse. I did some research on this problem and it seemed very common in this vehicle. So I had the master cylinder replaced on my car. The problem seemed to have been solved... again after 10 days I was proven wrong, the problem was back I again could not change gear as the bite was so low to the floor. I then had my car taken into a local garage and had the slave cylinder replaced. Again once after that was fitted to my car the problem had seemed to be solved however after 14 days again my problem was back! I took the car back to the garage and explained this to the mechanic. He then changed the master cylinder again and the slave cylinder again, in case either were faulty. Again the problem disappeared for a short amount of time but it was soon back again. I took it back to the mechanic and he had no idea, he changed a plastic pipe in case it had a fracture. Again the problem went away but was soon back again, the time in which the problem was reoccurring became shorter as time went by. I took the car back and he changed brushes under my pedals which had 'worn' as he thought this could be the problem. Again it was not. I gave up with the mechanic and had my dad bleed the clutch every time the car seemed to lose the bite. My dad then changed the plastic pipe and then a metal pipe. He also has changed the bleed nipple three times. Now I am having the master cylinder replaced again for the third time. Has anyone got any ideas in what could be happening with my car? Its costing a fortune and I seem to be keep running in circles, I am getting no where! Please feel free to give me your advice. Thank you :)