AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Raddylad

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About Raddylad

  • Rank
    Newbie

Contact Methods

  • First Name Gary

Profile Information

  • Ford Model Kuga
  • Ford Year 2013
  • UK/Ireland Location Lancashire
  • Annual Mileage 10,001 to 15,000
  1. Engine Rattle

    Hi mate. Sorry for the late reply. Got the car back today. Made up with it now. :) There where a couple of error codes on the diagnostics. But they said they couldn't understand why it come up with these codes. So they resets it. And uploaded fresh software. Car runs a dream now. Thanks for getting back to me. :)
  2. Engine Rattle

    Hi every1. I'm new to this site. I have a 2.0 tdci awd titanium x 2013 The car has done nearly 7000 miles. Yesterday I noticed an unusual rattle coming from the engine when I accelerate a little. Only seems to happen when the engine gets up2 temperature..... Also I've noticed the radiator fan is always on when I come bk from a trip out about 15 miles. Seems odd to me as the engine temp is normal. No warning lights on the dash. Checked oil level. Checked the water level for the radiator. No loss of power. But very annoying as I kno it shouldn't sound like this. Getting booked in tomorrow. Has any1 else had this problem. ?? Regards Gary.