AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


benni boi

Members via FB
  • Content count

    9
  • Joined

  • Last visited

About benni boi

  • Rank
    Newbie

Contact Methods

  • First Name Ben

Profile Information

  • Ford Model fiesta 1.4
  • Ford Year 1997
  • UK/Ireland Location Essex
  • Annual Mileage 0 to 5000
  • Interests Classic Cars
    General Automotive
    Motorsport & Racing
    Car Modification
    Entertainment
    Sports & Leisure
  1. Tail Lights

    Hi, I purchased some after market tail lights for my KA from auto tint design & they arrived today but when I went to fit the they don't fit, not a single bolt lines up. Does anyone know if Ford changed the bolt locations on later KA's? Mines a 2002 52reg pre Duratec engine
  2. I have a 2002 52reg KA Style that has standard steel wheels, I think they're 14's. I have noticed some XR2 Pepper Pot alloys for sale on eBay but they're only 13inch & I'd like to know if they'd fit? These are one of my favourite sets of alloys Ford made, I'm an XR2 fan Any help would be greatly appreciated
  3. Thing is yes I swapped the plugs, #2 plug to #1, but the problem still stayed at the #1 not move to #2 so can't be the plugs. I'm only a DIY mechanic with average knowledge but starting to think it sounds like it's running on 3 cylinders although I'm not 100% certain what that sounds like lol
  4. I haven't changed te spark plugs but I have swapped the #2 & #1 plugs around to see if it's the plug but it still does the same. As for fault code I don't have a fault code reader & it's only a 97 fiesta so no computer on dash
  5. I posted on here about my fiesta engine running rough & I was told that when you unplug the ht lead the engine should die. When you take the #1 plug lead off the engine stays running but when you unplug any of the other leads the engine dies as it should. I've replace the ht leads for brand new ones & replaced the coil pack for a 2nd hand one but still does the same. Does this mean then there is a problem with the cylinder?
  6. Mk4 Fiesta 1.4 Running Rough

    Thanks
  7. Mk4 Fiesta 1.4 Running Rough

    I know this may sound a little silly but where abouts is it located as I googled it & it said the right hand side of the engine bay but I can't see it. I know it's a cylinder with a hose top & bottom but I can't see it in the engine bay
  8. Mk4 Fiesta 1.4 Running Rough

    The air filter was replaced not long before I brought the car but I don't believe the fuel filter has been replaced
  9. Mk4 Fiesta 1.4 Running Rough

    Hi all, I have a 1997 mk4 fiesta 1.4 zetec-s engine fiesta which is running really rough. Originally the car had breathing problems, was idling at 2/300 rpm, so I changed the idle control valve & that cured that problem, now idling at 1000rpm, but it soinds rough. When you drive it there's not the poke that it normally has, 90bhp whem new, but im not sure whatthe problem could be. Any advice would be greatly appreciated