Curt201079

Budding Enthusiast
  • Content count

    11
  • Joined

  • Last visited

About Curt201079

  • Rank
    Member

Contact Methods

  • First Name
    Grant

Profile Information

  • Ford Model
    Mk1 focus zetec 1.6
  • Ford Year
    1999
  • UK/Ireland Location
    Kent
  • Annual Mileage
    5001 to 10,000
  • Interests
    Classic Cars
    Car Restoration
    Car Modification
    Entertainment
    General Automotive
  1. Don't think I could put even a burgler through eating my other halfs cooking
  2. Bat mobile !!!
  3. Hey guys !, So this morning I return from night shift only to find my other halfs car focus zetec has been stolen . I then get into my home to find house has been broken into and they helped them selves to the keys great !!! Then it dawns on me that my garage keys are missing brilliant my BMW e39 m5 also gone it just gets better font it !! Well it did because what the idiot scum bags didn't see is that they had been rubbing there hands together whilst smiling for the CCTV cam on drive and the garage lol wot a shame handed over to police who just happen to know them and caught them red handed with all my stuff ha ha all back and safe now lock em up throw the key scum !!!
  4. I done the gaps when I first put the plugs in found yesterday that the tps I purchased is faulty soon as I unplugged it whilst running all returned to normal . Its not my car it's my other halfs I have an e39 m5 she is learning to drive and its causing her a problem as she is at low speed most of the time which is when the issue is happening . I think if this don't solve it I will swap for a tractor as more reliable than a ford at this point also lol
  5. Bought and fitted fuel filter this morning from fords idle still same. How ever decided to unplug tps with engine running on tick over I did this when car was warm and starting to idle bounce and when I did it returned to normal ! Plugged it back on car returned to rough idle do I assume this is my fault ?? I must have a dodgy one if it is as I have replaced this already but was not from ford just a motor factors wot do u recon guys ?
  6. Should it really be a ford part I have read a lot about the focus not really likeing pattern parts ? Also would this if it is the filter only give me problems when warm and at idle and not any other time ? Sorry lots of questions just as you see it's a 1999 and don't want to keep spending and spending lol it's a brill car other than this issue all panels are still straight paintwork and interior above average for age don't really wanna have to get rid of it over something that will probably be simple but do have to draw a line at some point
  7. No I haven't done this yet will do tomorrow though thanks I'm in meopham thanks for ya advice will keep posted on how it goes !!
  8. Hi guys New to site which is very impressive not sure if I have done this in the correct way for help . My mk1 1999 1.6 focus zetec has the dreaded idle issue. Basically I so far have replaced the following : pcv valve and hoses, Idle control valve , Throttle sensor , Air filter , Maf sensor , Plugs leads coil, I can not hear any air leaks . The car starts fine runs fine at cold about 1200 rpm idle . When warm 750-800rpm at idle if I gently push accelerator at this point it picks up as soon as get to 1000 rpm it stutters and coughs till past approx 1100 mark then all fine again drives fine till I slow up at junctions etc etc again around 1000 rpm will kangaroo jump splutter etc does not stall yet lol any help would be greatly appreciated oh also no engine lights showing either .
  9. Newbie here !!!Some great help threads and even in most case better than I have been given from fords . Great site guys keep it up !!