AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Willy

True Ford Enthusiast
  • Content count

    3,301
  • Joined

  • Last visited

1 Follower

About Willy

  • Rank
    1.0 EcoBoost MR165 Mountuned

Contact Methods

  • ICQ
    0
  • First Name
    Willy

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta 1.0 Titanium X Midnight Sky
  • Ford Year
    2015
  • UK/Ireland Location
    Sussex
  • Annual Mileage
    15,001 to 20,000

Recent Profile Visitors

14,891 profile views
  1. Hi mate. Yep I have one fitted. Definitely worth doing. You feel the benifits straight away without any adverse effects on the gear change. I'll find you a link to my page. Another mod worth doing is the leather gator from the ST. Fits with a but of modding.
  2. I added extra chrome 😆
  3. They do now. It's called the ST Line
  4. Just to note that 125PS is still Tax exempt for the moment where as the 140ps is £20 I think. This is due to the different gearbox setup. A mapped titanium x was my option. Has more gadgets than an ST / ST Line etc, free road tax, better 0 - 60 than a 140ps. Great little car.
  5. I couldn't tell the difference between the two but I don't have an open cone filter.
  6. I must stop wasting money on the Fez 😂 For Sale
  7. Test fitted the AS Pipe and didn't notice any difference in profomance or sound.
  8. So the satnav is sold and purchased an AS crossover pipe. Opinions? Or stock pipe
  9. Welcome to the world of crap dab. Dab in general on cars is naff. The warm weather also doesn't help the signal. Personally I don't bother with dab now and stick to usb or bluetooth streaming
  10. Heres mine. There very similar. I put a bit of washing up liquid on the hoses when I fitted them. The engine cover is also a tight fit and sometimes needs a little foam removed where the pipe touches.
  11. Camera connector now sourced so just need to work out where the camera cables are on the loom.
  12. That would be great 😆 Strange how the original setup uses the large black plug connection for the camera but the satnav doesn't. I came across a connector on the net that would possibly fit How did you overcome the KM to miles issue? I've gone into the setting but found it was already set to english and won't select miles on the menu.