Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About PedroG

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
    C Max 1000 ecoboost
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  1. Thought I'd post an update on this. The dealership took the car in and 'updated' the engine management system. The trip computer now reads between 43 and 46 mpg (combined cycle) and it seems to be comparing well with 'actual' mpg. One thing I've noticed is that the gear shift indicator wants me to change up earlier now (5th at 30, 6th at 40) but the engine labours a bit if there's any load (uphill for instance), so I'm mainly sticking to my previous habits (5th at 40 and 6th at 50) and it still gives me better mpg. I also pushed it up to 70 on a level road and the mpg still crept upwards, so here's hoping! Cheers
  2. I suppose I'm a bit niave to assume they do what the say! Had it to work the past 2 days, 12 miles each way, open road and 3 villages en-route. MPG is sitting at 42.7, a lot better. I'll give it a long one at the weekend and see how it pans out. Thanks for all input guys. Pete :)
  3. Thanks for your input James. The car is a Ford Direct purchase, just got it last week, so a full service should have been done and everything back to manufacturers standard. I'm using it to work this week, so it's getting longer journeys, I'll keep an eye on it. Pete
  4. My C Max 1000 ecoboost had 10000 on the clock when I bought it, so I'd expect it to be well run-in and to be getting the best mpg I'm likely to get, however I'm getting 36/38 with a mix of mainly country roads and some town driving. Expected more, based on claims of 54 from the manufacturer, thought I'd maybe get around 45/48. The dealer I bought it from said I should be getting more. Any suggestions as to how I can improve this? Thanks
  5. Took it back to the dealer and they said it's the way it's meant to be. Showed me a focus that was exactly the same. Looks like that's that! <_<
  6. I'm wondering if this is a fault or not. When the radio is off the screen has a series of blue rectangles on it, as if it was still on but the brightness was turned up too high. I thought it would have been dark or at least all one colour. When the radio is on there's a graded blue effect, lighter at the top and bottom of the screen. When the SatNav is on there is a lighter band at the top of the screen. It looks sort of 'washed out', not good contrast and as if the brightness was too high. I don't have auto lights so only have the instrument light dimmer but that doesn't have much effect. I've looked in the settings but can't see any way of adjusting the screen settings. Any help appreciated.
  7. Hi Just bought a 2013 plate C Max Ecoboost recently, nice car, great to drive, bit disappointed with the mpg but haven't had it on a really long run yet. Looking for a bit of advice with the display screen but will see if I can find a suitable thread to post it in. Happy Motoring