AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


AlanD1983

Members via FB
  • Content count

    6
  • Joined

  • Last visited

About AlanD1983

  • Rank
    Newbie

Contact Methods

  • First Name Alan

Profile Information

  • Ford Model Mondeo 2.0 tdci Titanium X
  • Ford Year 2008
  • UK/Ireland Location Cheshire
  • Annual Mileage 5001 to 10,000
  • Interests General Automotive
    Sports & Leisure
  1. Hi, looking for some help as i am more of a driver of cars than a fixer. When i accelerate not all the time but sometimes the revs jump from say 2000rpm to 2800rpm for a couple of seconds then the engine sort of catches up! my first thought was clutch problems but to be honest i have no idea. thanks alan
  2. Hi, I have mk4 tit x sport, when I start if a morning it starts but only just! I engage the clutch then press abs hold the ford power button but it sounds like it's not going to start then just about starts?? Many help would be great thanks
  3. any idea where i can get 4 new ford blue centre caps 54-55mm. thanks alan
  4. Hi I have a mk4 mondeo titianium x, The front cigarette light doesnt work but the rear one does ? I have replace the fuse with several other new ones. Any ideas what it could be? Thanks Alan
  5. 57 Plate Mondeo 2.0 Titanium X

    Hi yes reverse light work perfect, the sensors in the bumper are factory ones. I get no tone at all when I engage reverse, there is no button on the dash anywhere. Is the buzzer located by the small fuse box in the boot? Thanks
  6. Hi, I have just bought a mondeo 2.0 Titanium x, the car is going great really happy but i noticed i have reverse sensors on the rear bumper but get no sound when I place the car in reverse even when I'm practically touching my garage door?? Do i need to activate them somehow or is replacement fuse needed?? Any help would be great. Many thanks Alan