SteveWhittet

Budding Enthusiast
  • Content count

    11
  • Joined

  • Last visited

About SteveWhittet

  • Rank
    Member

Contact Methods

  • First Name
    Stephen

Profile Information

  • Ford Model
    Fusion
  • Ford Year
    2007
  • UK/Ireland Location
    Aberdeenshire
  • Annual Mileage
    10,001 to 15,000
  • Interests
    General Automotive
  1. Thanx Ian, will have a look at those 2moro, pollen filter that behind the dash or behind the scuttle panel under the bonnet? Sent from my LG-D802 using Tapatalk
  2. Thanx will check 2moro, and just see how she goes I guess, 'let it develop' as my mechanic would say lol Thanx Sent from my LG-D802 using Tapatalk
  3. Got this when I scanned it 2nite, but it drove 25 mile from work white without a hiccup, Saturday was the first day it did it and it was very wet, could it just be damp in the connections maybe? When I started it this morning I could hear a 'running water' sound from behind the dash that I can't say I've noticed b4 but it's never been started without the radio on so can't say for sure if it been there all the time or not lol Sent from my LG-D802 using Tapatalk
  4. It is manual, no cruise control. Its a 1.4 style, 16v duratech I think it is. Sent from my LG-D802 using Tapatalk
  5. Oh right, thought you meant a number or model , it's a 5 speed manual. 5 forward one back Sent from my LG-D802 using Tapatalk
  6. Not sure, don't really know much about her car. How was I be able to find out? Sent from my LG-D802 using Tapatalk
  7. Hi, my wife's fusion 1.4, starting playing up on Saturday morning out of the blue, wouldn't idle properly and felt like it was holding back when driving almost like the handbrake was still on. It would stall when stopping instead of just idling. My friend came over with his code reader and the two codes it came up with was p2135 and p0704. He said it was to do with the Throttle Position Sensor and clutch switch something or other. Anyone shed any light on it? Any help greatly appreciated. Thabx Steve Sent from my LG-D802 using Tapatalk
  8. Thanx Sent from my LT30p using Tapatalk
  9. Any know the size of the nut in the center that holds the rear hub in place, need to know if I gotta get a socket on my way home from work Thanx in advance Sent from my LT30p using Tapatalk
  10. Cheers Mick, was hoping to strip it and take the hub to somewhere to get the new bearing put in, try to keep the cost down. Sent from my LT30p using Tapatalk
  11. Hi all, new here we have a 2007 Fusion Style 1.4 petrol and the rear wheel bearing went on my way home 2nite was just wondering how hard a task it is to replace. I'm pretty handy with a spanner and socket set but lack the knowledge really, but will tackle most things, i have stripped and re built the front suspension set up on our other car to replace the strut top bushes and didn't find that to hard. thanx in advance for any help received. ps can I follow this forum with my mobile app tapatalk?