Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Greg-powell

Budding Enthusiast
  • Content count

    47
  • Joined

  • Last visited

About Greg-powell

  • Rank
    Settling In Well
  1. Hi guys i got a focus ST what grade oil do they take?? Thanks Sent from my iPad using Ford OC
  2. I had the same issue and it was the speed sensor, and my odo only blanked out a few times randomly not every time! Sent from my iPad using Ford OC
  3. Told ya to start with the starter motor.... Sent from my iPad using Ford OC
  4. It should start if it's got wet like a set a petrol wouldn't but it's not a petrol Sent from my iPhone using Ford OC
  5. Unluckily it's not a petrol car there are hardly any electrics on it. I would first make sure u have power going to ur starter motor first. U could even take it off and test that it works it u wanted to. Crankshaft sensor will be in the engine block somewhere Sent from my iPhone using Ford OC
  6. Unless ur starter motor has compleatly failed, or hasn't got a feed from the battery Sent from my iPhone using Ford OC
  7. Could be crankshaft sensor the car won't even turn over if that's faulty Sent from my iPhone using Ford OC
  8. Not really mate just go to Halfords there paints are allways good Sent from my iPhone using Ford OC
  9. Just use high temperature caliper paint Sent from my iPhone using Ford OC
  10. Yeh cheers guys just as I thought. Iv also got a slight wobble on my steering wheel and it gets worse when I press the brakes at high speed but stops if I brake hard any idears? Sent from my iPad using Ford OC
  11. Hi guys iv had my ST-3 for 2 months now and for about the past month the front brakes have been squeaking. Was just wondering if any 1 else has had the same problem and what was the cause/fix? It's starting to get very annoying now! Sent from my iPad using Ford OC
  12. Yeh you could do that but then you would be putting on another hub with a worn wheel bearing so you would have to make sure that it's a good bearing Sent from my iPad using Ford OC
  13. Wheel bearing mate I'm supprised it hasn't collapsed by now as u have left it seriously long!! Sent from my iPhone using Ford OC
  14. Mine just passed mot with HID in they sed nothing 2 years running. I didn't had washers either. As long as there projected headlights so they don't blind people they seam to get through MOT fine Sent from my iPhone using Ford OC
  15. Proper ST ones are much better I had HIDs in my mk1 focus and iv just got an ST there so so so much brighter!!! Sent from my iPhone using Ford OC