• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


ch1975

New Member
  • Content count

    1
  • Joined

  • Last visited

About ch1975

  • Rank
    Newbie

Profile Information

  • Ford Model
    fiesta ST
  1. my fiesta st 55 plate 40000 miles has developed a tapping at the top end from 2000 rpm up, and was getting lazy to start (turning over about 5 seconds before firing. did a compression test and found pot 1 only had 8bar, 2 had 11bar, 3 and 4 both had 12 bar. removed head today expecting to find a hole in piston or a valve problem but all looks ok, waiting for head coming back from testing (vacuum and pressure and a skim), has anyone got any idea? did a sniff test before strippig all ok. head gasket looks ok cams are both ok, (will need a polish on caps) but no pitting or gouges just discolouring all followers look ok. next step is bottom end off but it was deffinitly a top end tap