• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


big g1985

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About big g1985

  • Rank
    Newbie

Contact Methods

  • First Name
    Gary

Profile Information

  • Ford Model
    C max
  • Ford Year
    2004
  • UK/Ireland Location
    RhonddaCynonTaff
  1. Water Leak Into Boot

    Not light cluster either had it in and out and all dry around there
  2. Water Leak Into Boot

    Seal is fine I sat in the car whilst the wife sprayed it with the hose for 10min
  3. Water Leak Into Boot

    Got a water leak into the boot of my wife's 54 plate c max. The garage sealed around the wiper as they thought I was coming in through there. Well it's still leaking. I've had the trim out today and a hose pipe on the go. It's not leaking around the light fitting but it's damp up around the top of the inner panel. I can't see where it's coming in and there's nothing obvious. I had one drip by the seat belt mount on a double skin but again I can't see where it's coming from Any help will be greatful Pic shows where it's dripping in by the double skin
  4. Strange Electrical Fault

    Turns out it was moisture in the cabin fuse box corroding the contacts supposibly a common fault
  5. Strange Electrical Fault

    After my wife drove through a big puddle we e had a strange electrical fault when u lock the car (54 plate 1.6 tdc) Basically when you lock the car the wipers will operate a small amount and the heater control lights illuminate then go out. I've check the fuse box in the engine bay and I've noticed here is a loose live cable at the top of the box Can't see where it should attach. I've moved it out of he way I case it was shorting on something but I still have the same fault Any help will be appreciated Thanks
  6. Newbie South Wales

    Hi new to the forum and I'm in need off help with my wife's cmax