Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


big g1985

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About big g1985

  • Rank
    Newbie

Contact Methods

  • First Name
    Gary

Profile Information

  • Ford Model
    C max
  • Ford Year
    2004
  • UK/Ireland Location
    RhonddaCynonTaff
  • Annual Mileage
    0 to 5000
  1. Not light cluster either had it in and out and all dry around there
  2. Seal is fine I sat in the car whilst the wife sprayed it with the hose for 10min
  3. Got a water leak into the boot of my wife's 54 plate c max. The garage sealed around the wiper as they thought I was coming in through there. Well it's still leaking. I've had the trim out today and a hose pipe on the go. It's not leaking around the light fitting but it's damp up around the top of the inner panel. I can't see where it's coming in and there's nothing obvious. I had one drip by the seat belt mount on a double skin but again I can't see where it's coming from Any help will be greatful Pic shows where it's dripping in by the double skin
  4. Turns out it was moisture in the cabin fuse box corroding the contacts supposibly a common fault
  5. After my wife drove through a big puddle we e had a strange electrical fault when u lock the car (54 plate 1.6 tdc) Basically when you lock the car the wipers will operate a small amount and the heater control lights illuminate then go out. I've check the fuse box in the engine bay and I've noticed here is a loose live cable at the top of the box Can't see where it should attach. I've moved it out of he way I case it was shorting on something but I still have the same fault Any help will be appreciated Thanks
  6. Hi new to the forum and I'm in need off help with my wife's cmax