Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Squeekie

Budding Enthusiast
  • Content count

    29
  • Joined

  • Last visited

About Squeekie

  • Rank
    Member

Contact Methods

  • First Name
    Bob

Profile Information

  • Ford Model
    Fiesta ecoboost 1.0 125ps
  • Ford Year
    2013
  • UK/Ireland Location
    Other/NonUK
  • Annual Mileage
    0 to 5000
  1. Mine's 125bhp Titanium and it works fine. Very happy with the remap. - John
  2. I remember actually seeing a video about this some time back. Found it: http://www.youtube.com/watch?v=vpzQbFGP4MI#t=287
  3. I have the latest map update (from last week) and no issues with power cutback or start/stop function. It's all good :) - John
  4. As for warranty: http://www.superchips.co.uk/s/warranty You're really trying hard to make superchips look bad, but unless you have any proof to back these statements up, its just baseless claims. My personal experience with them has been positive, and the performance gain is very noticeable with standard RON 95 petrol and everything else stock. - John
  5. That's a bold claim, on what grounds do you state that? The warranty part is of course a valid point, all though superchips does give uk users a limited warranty. I think most people are just disappointed with the long wait and less than hoped for bhp gain. - John
  6. Here in norway a Fiesta ST costs £10-12k more than a 1.0 ecoboost titanium, so it's way more expensive.. - John
  7. Same here. Didn't see it until you pointed it out. - John
  8. I would. If they don't have an update for the 100ps version, maybe you can ask for the 125ps map instead. If I'm not mistaken, there is another guy in here with 100ps running the 125ps map. I guess it should be fine _if_ the two versions are mechanically the same. - John
  9. Well, I got a reply back from superchips yesterday. I'll just paste some of what they wrote: "We have recently seen another Fiesta and a B-Max 1.0 EcoBoost and have made some further tweaks to the software. I have made the new file available to your bluefin for you to download and test. You will almost certainly notice the rev limit has been extended slightly but the cars performance should be much more even across the rev range than before. " One thing is for sure, the problem is gone now! :D No issues with stuttering/power cutback under full throttle in 1st gear. I even did a couple of 0-60mph tests on my way back from work today: Flat road: 8,3 sec (Slightly uphill: 8,9 sec) I used Torque android app with GPS measuring. Basically, it was the map that was the culprit after all. The only negative is that the fuel consumption now seems to be the same as stock map, whereas the old version gave a 10% reduction. - John
  10. Just to clarify, the problem we're talking about has nothing to do with revving it in neutral/1st gear with the clutch down, it's about uneven power output/cutback when driving in 1st gear under full power. As in 0-30mph is slower (and stuttering) with the remap than stock map. - John
  11. Yes, I have also sent them an email. Everyone with this issue should drop off a mail. - John
  12. You mean it doesn't give full power before after 3.5k rpm? Where did you find this info? I made a short video of the problem. Unfortunately, it doesn't come across very good in the video. It feels a hell of a lot worse than it looks. You can see the rpm is hesitating between 3 and 4.5k rpm in 1st gear. It's, if anything, easier to see on the speedo between 20 and 40 km/hour where you can see its pretty slow. If you turn up the volume, you can also hear the sound is different as well. Sorry for the shaky video, I had to told the camera with my left hand http://www.youtube.com/watch?v=LznkBN94OXw - John
  13. I really don't know. Only thing I can say is that it's higher than stock map, which is expected ^_^ - John
  14. This all sounds correct, but that would mean the wheels are starting to spin every time I floor it in 1st gear at around 3-4k rpm. It doesn't feel like they are, all though I can't be certain. Also I do get some initial wheel spin when popping the clutch without powerloss/TC kicking in. I really should get some summer tires to see if improved traction would help. It was a sunny day today, so the roads are dry and nice. I have no extra weight in the back of the car either. As for the Torque app, I set the car weight to 1150kg (2535lbs). The torque and hp numbers was just for fun, but the 0-60 time was directly compared to what I measured when running stock. - John