Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Benjamun1991

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About Benjamun1991

  • Rank
    Newbie

Contact Methods

  • First Name Benjamin

Profile Information

  • Ford Model Fiesta
  • Ford Year 1999
  • UK/Ireland Location Somerset
  • Annual Mileage 5001 to 10,000
  1. Misfire Help???

    Hi I own a ford fiesta 1999 1.25 zetec. Had a few issues which gradualy have got worse. When i bought it it sounded like a tank, Now at first i thought it may be as simple as coil pack or ht leads or even plugs, As it was misfiring My mate who came with me took of all ht leads whilst engine was on ( one after another after putting the one pulled of back on) and if you pulled ht lead 2 out it wouldn't do anything, So we knew it was down to cylinder 2 not firing) So got a new coil pack and slightly improved it .. So of my mates ford focus we used the ht leads.and no different other than it made it sound slightly better.butperformance was still rubbish. Tried changing number one spark plug and placing it in number 2 and number 2 in one and no different, still wasn't firing on 2.. tried redex... nothing, what i did notice was oil had leaked in to the number 2fuel injector as rocker cover gasket was bust. .got a rag and and stuck it in the fuel injector holes and got rid of what i could... as well as cleaning battery terminals... the car doesn't start asoon as i flick the ignition it struggles but after doing those 2 things ( when it was on empty) running on fumes) it started first time and sounded and felt like it wasn't missing,,,so next morning refuelled.... And back to where we started,, tried cleaning injectors out again,, no different. Now no i haven't done a compression test BUT! there is no coolant missing from my engine what so ever... its still slightly above max... oil is the right colour... and temperature doesn't go over half way... It does drink oil but i think possible oil leak from a seal maybe.. no blue smoke when driving...Literally don't no what else to try suggest ive even tried this product from halfords... Bars Leak Radiator Sealer 135ml. suppose to fix coolant leaks in head gaskets ect...now when i before doing this whilst driving to Halfords i had an issue with the idling... would come to a stop and it would drop to around 700 and climb back to 1000 ( almost felt like it was going to cut out but never did) bought the bars leak and put it in before leaving . let it run around the engine for 10 mins then set of... the ideling issue was gone ..... ;/ Now if i pull number 3 spark plug out it changes the engine noise and but doesnt quite go to cutting out like if i pull out 1 or 2 ) now pulling a way in 1st 2nd or 3rd is dreadfull.. when i go to pull away in 1st my foot can be all the way down on the accelerator and itll feel like im cluthcing away... then boom. power kinda kicks in but really intermitent and its no way near got the power it had when i first got it?Really unsure on what to do and no other forum seems to hold an answer for my issue.... PLEASE SOME ONE HELP ME BEFORE I TAKE A HAMMER TO THE !Removed! THING THEN TORCH IT!!!
  2. Hi I own a ford fiesta 1999 1.25 zetec. Had a few issues which gradualy have got worse. When i bought it it sounded like a tank, Now at first i thought it may be as simple as coil pack or ht leads or even plugs, As it was misfiring My mate who came with me took of all ht leads whilst engine was on ( one after another after putting the one pulled of back on) and if you pulled ht lead 2 out it wouldn't do anything, So we knew it was down to cylinder 2 not firing) So got a new coil pack and slightly improved it .. So of my mates ford focus we used the ht leads.and no different other than it made it sound slightly better.but performance was still rubbish. Tried changing number one spark plug and placing it in number 2 and number 2 in one and no different, still wasn't firing on 2.. tried redex... nothing, what i did notice was oil had leaked in to the number 2 fuel injector as rocker cover gasket was bust. .got a rag and and stuck it in the fuel injector holes and got rid of what i could... as well as cleaning battery terminals... the car doesn't start asoon as i flick the ignition it struggles but after doing those 2 things ( when it was on empty) running on fumes) it started first time and sounded and felt like it wasn't missing,,,so next morning refuelled.... And back to where we started,, tried cleaning injectors out again,, no different. Now no i haven't done a compression test BUT! there is no coolant missing from my engine what so ever... its still slightly above max... oil is the right colour... and temperature doesn't go over half way... It does drink oil but i think possible oil leak from a seal maybe.. no blue smoke when driving...Literally don't no what else to try suggest ive even tried this product from halfords... Bars Leak Radiator Sealer 135ml. suppose to fix coolant leaks in head gaskets ect...now when i before doing this whilst driving to Halfords i had an issue with the idling... would come to a stop and it would drop to around 700 and climb back to 1000 ( almost felt like it was going to cut out but never did) bought the bars leak and put it in before leaving . let it run around the engine for 10 mins then set of... the ideling issue was gone ..... ;/ Now if i pull number 3 spark plug out it changes the engine noise and but doesnt quite go to cutting out like if i pull out 1 or 2 ) now pulling a way in 1st 2nd or 3rd is dreadfull.. when i go to pull away in 1st my foot can be all the way down on the accelerator and itll feel like im cluthcing away... then boom. power kinda kicks in but really intermitent and its no way near got the power it had when i first got it?Really unsure on what to do and no other forum seems to hold an answer for my issue.... PLEASE SOME ONE HELP ME BEFORE I TAKE A HAMMER TO THE !Removed! THING THEN TORCH IT!!!
  3. My 99 Ford Fiesta Is Missing On Cylinder 2 Help!!!

    Ok no such luck its now a case of me hitting my head against a brick wall... IN THE LAST UPDATE i said it wasnt missing and it wasnt .... but it is again, ive tried cleaning the fuel injectors ect again.... nothing.. doesnt start straight away either now? put some fuel and redex in and suprise nothing... i fail to see how it is my head or any of that as no milky oil and no coolant loss. to be sure i added some coolant leak stuff that seals any cracks in head gaskets ect.. it did help my idle issue,, when braking at junctions it would idle at around 700 rpm and feel like it was gunna cut out,, i stuck that stuff in and instantly it stopped the idle issue?? But still not firing on cylinder four. It does sound more like a car than a tank but cant work out why cylinder 2 ... Like i said plugs leads and coil changed,,, I will try find a compression tester but what else can cause this,,, crankshaft sensor perhaps ? any other sensors im missing.... Please help me ,,, doing my head in!!!
  4. My 99 Ford Fiesta Is Missing On Cylinder 2 Help!!!

    Ok update.... got bored and had a play, Decided to check under rocker cover, ROCKER COVER GASKET WAS POURING OUT ..... That is the issue!!! basically the oil had seeped out and into my fuel injector on number 2 .... contaminating the fuel... took number too out and cleaned inside carefully using a rag. Cleaned rings and put back together ......had to move it quickly back in to my space... and there it was At first before id done this it would never start first time.... But this time it did so i turned it off a few times... and back on and every time boom.. it worked... before when missing my seats vibrated and my exhaust sounded like a helicopter ...now hardly any vibration and didnt sound to bad on exhaust .. obnly a slight misfire but the car is out of fuel so will try putting a new rocker cover gasket on some redex and fuel and fingers crossed thats the end of it!!! will update within 48 hours!
  5. My 99 Ford Fiesta Is Missing On Cylinder 2 Help!!!

    Sorry its a 1.2 .. only 85 k on clock!
  6. Hi all, I recently purchased a ford fiesta 99 plate.... with a missfire. I thought it was most certainly the coil pack as these are known to go on fords.So changed that an an ever so slight change . running slightly better but no where near the full. still missng..bit more power so checked the leads.number 2 wasnt sparking... so changed lead for 2 and again a slight but ever so slight change again sounded a tad better.Still missing... I know it is cyclinder two not firing as changed 2s spark plug in to 1 and 1 in to and 1 in two didnt fire it either.plugs seemed all to be ok...recent plugs two..the problem was before they were changed...Now no signs of a head gasket going.. Checked rocker cover... clean oil ... checked the water tank.. it was black and smelt sweet so i assume thats anti freeze. ( also my exhaust smells slightly sweet)No over heating issues either. done 247 miles with it missing and no cut outs or breakdowns at all just a tad bumpy... Any suggestion as im banging my head against a brick walls!!!