AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


vinzchau9

Members via FB
  • Content count

    7
  • Joined

  • Last visited

About vinzchau9

  • Rank
    Newbie

Contact Methods

  • First Name Vin

Profile Information

  • Gender* Male
  • Ford Model Focus
  • Ford Year 2001
  • UK/Ireland Location Greater London
  • Annual Mileage 15,001 to 20,000
  • Interests General Automotive
    Car Restoration
  1. Hi Been experiencing intermittent flashing of the traction control light for a few weeks now. Would anyone have any idea what could be causing the traction light to flash intermittently? As well as that i'm experiencing a vibration like noise when I go over a hump or rough patch of road and sometimes a juddering sensation when I apply the brakes. Could it be the wheel bearings or abs sensors? Thanks
  2. Ford Focus Mk 1 - Abs Tone/reluctor Ring?

    Thanks, yea I've just checked and realized its part of the wheel bearing assembly. Would anyone have any idea what could be causing the abs and traction lights to flick on intermittently? As well as that i'm experiencing a vibration like noise when I go over a hump or rough patch of road and sometimes a juddering sensation when I apply the brakes. Could it be the wheel bearings or abs sensors? Thanks
  3. Hi I've been experiencing abs and traction control lights coming on intermittently with a juddering sensation when I apply the brakes. I think this is down to the ABS reluctor ring which may need changing, however could anyone tell me where I can source a replacement ring for the front hubs? I've been searching online but come across rings for the rear only. Thanks
  4. Engine Misfires When Cold Only

    Thanks for the replies guys. My Focus is starting first time now. It turned out to be the CHT sensor as suspected which I replaced, however I had to remove the alternator to get to it which was a beast to take off, but managed to do so after hours of graft. Also cleaned up the throttle body housing which looked dirty too!
  5. Engine Misfires When Cold Only

    Thanks, No lights on the dash, however I will change my fuel filter as its long overdue and try using fuel injector cleaner. I've done some looking around and found that it could be the cylinder head temperature sensor. The CHT sensor sends signals to the ECU, if the sensor is faulty and thus sends incorrect , or no info to the ecu as above, the fuel and air mixture will be incorrect and thus do as you describe resulting in poor running and no start situations temp dependent. Has anyone experienced this?
  6. Engine Misfires When Cold Only

    Any ideas anyone?
  7. Hi Just joined the forum and looking for some friendly advise as well as offering my advise on issues. I've recently developed a problem with my Ford Focus Mk1, 2.0, 2001. Each time I attempt to start my focus when the engine is cold it misfires several times, then once I've hit the gas and try again it starts. Sometimes it will start first time but it feels like the engine is struggling. If I switch off the engine when its warm and switch back on again, it will start first time no problem. Also I've had no issues when the engine is idle too. I've changed the battery, spark plugs (gapped correctly) and voltage checked the HT leads but to no avail. I'm thinking it might be a fuel problem, could it be the fuel filter as I know this needs changing? Also when I took the old spark plugs out they looked black at the spark end, could the rich mixture be an issue? I've done just under 90k mileage. Thanks Vin