Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


BenW

Budding Enthusiast
  • Content count

    241
  • Joined

  • Last visited

About BenW

  • Rank
    Feet Under The Table
  • Birthday 08/09/1985

Contact Methods

  • ICQ
    0

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta mk7
  1. Hey. I already know this. Just seemed easy to get a resonably accurate figure with my method. A 41.25litre fill up = 9.085 315miles on that tank = 34.67MPG I've been working it out over several tank fills the last few weeks. (I drive 100miles a day for work). As oringinally stated, my 2litre st did an actual MPG of between 29.5-32.5 hence my confusion? Cheers.
  2. Hey All. Just a question really, I have a new fiesta and done about 7000 miles in it now. However I don’t really seem to be getting great MPG. I motorway drive 85% of the time between speeds of 65-80mph. On a full tank (45 litres) my car will do between 315-330 miles. I don’t "rag" my car, I don’t accelerate overly fast and as said I do mainly motorway driving. From my workings to work out ACTUAL MPG. I take the amount of miles my car does and divide it by how many gallons my tank takes (9.91). 45 litres divide by 4.54. So lets say on average 337.5 miles per tank (when my car says its on 0 miles + the 15miles reserve). DIVIDE that by 9.91 = 34.06MPG Does that sound right??? ON paper it was meant to be 40+ and I’ve driven it extra careful on a take to see if makes a difference, that’s the 330miles!! My previous fiesta... 2litre ST had an actual MPG of 31.5MPG? What’s wrong? I’ve changed to premium/ultimate petrol, used different suppliers, no difference. Using my maths, what’s your MPG on the 1.6 Petrol engine, or other models to compare? Sorry if repeat post, Cheers. Oh and the MPG on the trip computer lies!! :P 45 litre tank = 9.91 gallons. Actual miles / 9.91 = MPG.
  3. same here :) i just go to ipod function and press the pause to stop playing. Very annoying though. A note however is that the "Phone name" function on the stereo / Iphone voice control feature now works on the iphone 3.1 update. Unfortunately the mic which recognises your voice is still on the iphone and not the car mic..... an improvement never the less.
  4. Front 2 way 17cm 180 watts : pioneer ts-h 1703 Rear are 3 way 17cm 180 watts : pioneer ts-g1703 correct??? :)
  5. im confused. so the speakers i would need are 17cm 2 way & 17cm 3 way?? i thought i needed 6" by 8"'s e.g. the pioneer ts-h687 can someone please confirm the actual size of speaker i need and also the actual model number of the pioneer's as that pdf file is unreadable :(
  6. hey. that did not help i was unable to unpair the phone, just stuck on the screen when tried to "debond" it. I went for the scary suggestion of yanking a fuse out.. which actually worked :) Basically it was fuse F2. F as in, from bottom left, A,B,C,D,E,F row to the right and the second use up (7.5 amps). I pulled that out and the whole dash went dead. put it back in and it all lit up again and all the fans came on too... Was pretty scary, but the head units memory had been reset, all radio presets gone and more importantly the bluetooth now paired to my phone and worked. Cheers again :)
  7. Mine has just started doing this!!!!! :o Not been able to use bluetooth for the past few days, exact problem!! *continues to read* P.s. love the forum ;)
  8. got it back :) Just gone and collected my car, has been fully valeted (as per my expectations). Filled back up with petrol and seems to be working fine. just drove for 60 miles, all good!! As expected the fuel pump was at fault! Cheers all :)
  9. yup, bit pants but will give them a ring tomos to see if any update! Not overly impressed but as long as get it fixed. Also really very concerned about where my car being kept, and any damage etc it may be getting if its just sat in a parking space :S Spose i will just get them to fix it but it more hassel!! :( Anyway, will keep u posted.
  10. Spoke to ford today. Siad the fuel pump at fault and awaiting parts. Estimated delivery of the parts needed between 21st-28th Aug! grrrrr. Not that good really i guess, I have told them to ENSURE its fully fixed as i cant afford to get stuck again. I have too much responsibility at work to mess about and if it goes wrong again I will keep the courtesy car for the time it takes them to order a new fiesta and have it delivered! I was/am not happy about it all. Also not impressed that they will just be keeping my car for a couple of weeks in their car park! I will be around the car like a hawk as it went to them spotless. Again, they will know this up front so will have time to ensure there are no dents or scratches. Anyway, that my latest update. Just need to wait for the parts and them to fit it i guess......
  11. cheers muchly! :) yeah, what a few trips to london and 100miles a day will do. Not forgeting my dealer is 50 miles away and its been back once etc. Im feeling positive, at the very least will get a good valet on the car and fuel again ;)
  12. AA will give me a car for 3 days by which time my car should be done OR dealer provide me with a car.
  13. lol, i know bad eh!! I do 100 miles a day for work and often have trips to london... again for work.... making a shiyte load on expenses so not too worried. And i got it for that anyway, previous ST costing me a fortune! :) will be with dealer 2mos so shud be sorted soon. thanks
  14. gutted, i feel for you. I really do :( Mine died today :(
  15. Right, yes... as topic heading suggests, had the unfortunate experience of my beast dying today!! About 5mins into my journey today, driving along doing about 50mph, *pop*, car looses all power and i have to pull over. Could not get the car started, engine was ticking over but not coming to life. There were no differenced to how i was driving, i was just cruising along at about 50mph for a few mins after i started out 5mins before! Pulled up on the side of a road and left the car alone for about 5mins. tried again but sadly nothing. Just ticking over but the engine was not firing up. I had to resort to calling the AA out, after about 20mins the AA turn up. He has a listen then does some basic checks with the battery etc. Plugs his fancy laptop into my car that reports "Ignition coil fault (primary)". He then has a play with the connectors and tried to start the car again but still not firing up. At this point im starting to keep in good spirits but starting to worry. Cutting a long story short he tests the fuses and the "fuel pump fuse" which looks after the ignition coil, fuel pump and lander/oxygen sensor has blown. He replaced the fuse and gave the car another go, YESSSS, it works. car started up fine rev's came down EXCELLENT..... NO!!! 5 secs later car cuts out again and won’t start. Check the fuse and its blown again. (2 fuses blown). I start to worry and the AA guy then spends some time on the phone to the tech guys at his head office and come back with some ideas. He checks the fuel pump cable under my back seats, removed the battery and checked all the connections under the fuse box and re-seats all the connections from the ignition coil. 2 hours later puts it all back, new fuse tried again. Same. Fuse blows and engine cuts out and wont start again :9 EPIC FAIL!! I had to get toed home, oh the shame!!! Basically, as the fuses were not just blown, they were obliterated!! There is an electrical fault with my car. The AA guy said its the only new fiesta he's come across with such a problem and non of the guys he was speaking to on the phone came across it either. He has asked I pass on the details to him when it gets fixed so he knows as he was trying very hard to get it working for me :'( I managed to speak to the dealer before they closed and there were very shocked and apologetic. My car is getting picked up 2mos and toed back to the dealer for repair! The AA guy did a few things and said one of 2 things at fault, either the Ignition coil or the fuel pump. Likely the ignition coil due to how the fuses were blowing up!! Not overly happy and a bit screwed for work as i commute 100miles a day :S Will keep you all posted but one to watch out for, for those that have similar spec etc it happened to mine on 2500miles!! Cheers, ben. :(