• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


jlarder

Budding Enthusiast
  • Content count

    7
  • Joined

  • Last visited

About jlarder

  • Rank
    Newbie

Profile Information

  • Ford Model
    2003 tdci 115 bhp
  1. Ford Focus 2003 2Litre Estate

    thanks for info. devez JRL
  2. Can anyone please help with the following The socket for removing the locking bolt (one on each roadwheel) is missing for the above vehicle. I dont have any numbers of this bolt to order a new one. has anyone any suggestions of how to remove these bolts so that I may order a new set, and socket Many Thanks JRL
  3. Thanks for info. JRL
  4. Am having problems with the windscreen wipers they are working perfectly OK but when switched off are not returing to the park position any explanations and remedy please Many Thanks JRL
  5. 2003 TDCI Mondeo 115 BHP

    Thanks for information. Will inspect same. JL
  6. 2003 TDCI Mondeo 115 BHP

    Tanks for info. will test out still further. Many Thanks
  7. When accelerating with the vehicle from being stationary, and then taking foot of accelerator the Revs remain at approx 1100 or thereabouts for a short time and then gradually fall back to 750 which I believe is the correct speed. The actual feeling is that of the accelerator being jammed in the partly open position at those Revs (approx 1100) by some mechanical means ie. Sticking accelerator pedal although this is not the case. On starting from cold or hot the revs. are 750 Would be pleased for any information regarding this problem and the remedy Many Thanks JRL