AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


rickb

Budding Enthusiast
  • Content count

    7
  • Joined

  • Last visited

About rickb

  • Rank
    Newbie

Profile Information

  • Ford Model
    mondeo
  1. should be 5947
  2. hi there yes the resistor pack burns out, its located pasenger side on the heater box (high) normally white plastic about 3 inches by 2 inches held in with small torx bit screw with wiring plug on the front,somtime this plug melts aswell,check it out first before you go to the scrappy incase you need the plug aswell......
  3. im glad you sorted it....... : :D
  4. i know this is an old forum but is a common one on escort and mondeo diesiels the advance solinoid control valve on the pump is knackerd they cannot be repaired,they are screwed into the front of the diesel pump and take 10-15 mins to change....you can buy them from http://flag-diesel.rivousel.com/FlagDiesel/index.htm item number Flag rev 82-1664 at £45 very quick to deliver.... you need a 27mm spanner to remove it.....the two wire from it go to a joining plug on the underside of the front panel...symptons rough idle (steady but kicks) plumes of white /grey smoke, exhaust smells of diesel clears roughly at 3700rpm or 70mph in top,turbos a bit laggy....if this sounds like your diesel change it......if you get someone to turn the ignition on you should hear it click a few times
  5. sounds like a siezed turbo bearing,the turbo proberly isnt spinning at all,hence no power no smoke,remove the turbo induction pipe and see if you can turn the turbine....hope this helps, turbos can be bought from most breakers for £30.....
  6. sounds like a siezed turbo bearing,the turbo proberly isnt spinning at all,hence no power no smoke,remove the turbo induction pipe and see if you can turn the turbine....hope this helps, turbos can be bought from most breakers for £30.....
  7. hi there i had the same problem with my 2000 2.5 auto, under the plastic bottom case of the airbox on the top of the gearbox is a round multi plug just to right or the gear quadrant selector,this had filled up with g/box fluid i blew out the oil and filled the switch on the gearbox with silicon and plugged it back in,its been fine ever since that was six months ago and 9000 miles,its like the overdrive is dropping in and out...hope this helps