matt141085

Budding Enthusiast
  • Content count

    14
  • Joined

  • Last visited

About matt141085

  • Rank
    Member

Contact Methods

  • First Name
    Matthew

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta Zetec S
  • Ford Year
    2009
  • UK/Ireland Location
    Kent
  • Annual Mileage
    10,001 to 15,000
  • Interests
    Classic Cars
    General Automotive
    Motorsport & Racing
    Road Trips
    Food & Drink
    Entertainment
    Computers & Electronics
    Arts & Crafts
    Sports & Leisure
  1. I am so glad I have seen this thread! Thought I was going crazy! My front wheels squeak exactly as described. Mine only started when I had the discs and pads replaced in April this year. I got the mechanic who did the work to look at it several times and every time he came back to me and said he couldn't hear the squeaking and it wasn't the brakes! I took the brake pads out and roughed them up a little, the squeak stopped for a few days, then it came back with a vengeance! Seeing as I only had the pads replaced in April, they obviously haven't amended the compound since this thread started! Can anyone recommend where I might be able to find some brake pads that are not the squeaky ones, or what I should be looking for?
  2. Hi all, Can anyone recommend a decent set of brake pads for my 59 plate zetec s? Thanks in advance to anyone who responds. Matt
  3. Hi to anyone reading this, Just an update on the squeaking situation! The squeak came back after appox 2 weeks so I booked it in for the wheel bearing to be replaced (Ford part). This lasted all of 24hrs before the squeak came back, so now I can't help feel like like I wasted £190 on a bearing that clearly did not need replacing! Does anyone have any clues as to what else is connected to the wheel that could create a rotational squeak? I think I am losing my mind now!!
  4. I did look at the Titanium with all the toys however the ZS I bought was better suited for me. I have the privacy glass and the 17" alloys (street pack). I used to have a G reg xr2i which was so basic it didn't even have power steering but I loved that little motor. Driving used to be fun without the need for all the gadgets, I guess the ZS is a close to it as I could get on the newer models. Each to there own obviously but I already know that when I have my midlife crisis, I want my old skool mustang to be old skool...the way they were!
  5. I too have a silver beast that I wash weekly! Amways shampoo and Amways silicone glaze has done me proud! Feels like glass after a polish! Autoglym tyre dressing seems to keep the tyre walls black for a while too! However after reading the above about Meguiar's Hot Shine, I am keen to give that a go!
  6. Wouldn't it be easier just getting a set from Halfords that are designed for the car? It's not like you will be impacted by the passenger side being 1 cm shorter! Just a thought!
  7. Go for Ford! It may have a few rattles and not be kitted out with all the tech but they are fun to drive and cheap to run! My ZS has many similarities to my old xr2i which was a great little motor! Good luck with whatever car you go with! One downside to owning the Swift would be that you would have to join the suzukiownersclub forum..........they are not as nice as us lot!
  8. I broke the white clip on mine about 6 months ago!! It is still secure without it so you will be fine until Tuesday! It is held by the 2 bolts along with the rivet and the bonnet sits on it, so it aint going anywhere!
  9. My ZS!
  10. Sounds like Ford trying to fob you off! Burning and coolant bubbling over is not normal! I would seek a second opinion!
  11. I would have to say the ZS, however I am biased on my decision! I want the leather interior and would't mind the upgraded stereo from the titanium!
  12. I had the same problem, ended up getting the AA out as I didn't fancy driving it home and couldn't lock it! He said it was a faulty bonnet catch but slammed it shut with brute force! I took it in to Ford and they refused to replace it even though the AA mechanic said it needed replacing!(It was under warranty at this point). All Ford did was to grease it up big style! Seems to have done the trick! My suggestion is to either call your breakdown if you have it or grease the hell out of it!
  13. Hi, thanks for the response. My mechanic has tried this but conveniently it never seems to squeak when I need it too! (The irony) It seems to have died down a lot on the "squeaking front" the last couple of days but is doing it every now and then! We came to the conclusion it might be the bearing too! There are potholes everywhere at the moment and I have not been able to dodge them all unfortunately! Just seeing how it goes for the next week and then will replace the bearing! Hope this does the trick! However not looking forward to the bill considering I just shelled out for a major service/discs and pads! I will update this thread if I do get some sort of diagnosis! Many thanks again!
  14. Hi, I have just had a new set of discs and pads fitted on my 59 plate Fiesta Zetec S and since then my offside front wheel is making this horrific squeaking when driving at low speeds. I have had a mechanic take a look, even took the brakes off and refitted differently to see if the squeak can be stopped! This obviously hasn't worked and even he is stumped by my predicament! It is is best described as a rotational squeak and it sounds like a giant mouse is squeaking as the wheel is turning, however it stops making the noise after I get over 30mph. It seems to only do it once I have been driving a little while in start/stop traffic! Does anyone have any ideas what it could be, or had the same problem? Thanks in advance to anyone that replies!