Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


AaronGall

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About AaronGall

  • Rank
    Newbie

Contact Methods

  • First Name
    Aaron

Profile Information

  • Ford Model
    Ford Fiesta MK6 LX 1.25L
  • Ford Year
    2014
  • UK/Ireland Location
    Dublin
  • Annual Mileage
    0 to 5000
  • Interests
    General Automotive
    Computers & Electronics
    Sports & Leisure
  1. Hi all, i was under the panels this morning having a look up at my clutch pedal as its been acting up lately, Found out it was just the clip holding the pedal to the rod was loose, So i clamped it tight with two cable ties until i get it fixed properly.. It has now fixed the problem with the clutch :D. However when i was doing this i came across a plug that was hanging down right beside my clutch pedal were the pedal meets the rod. It looks like there is something supposed to plugged into it but i have no idea what it is!! All my lights/wipers/radio/windows etc all work perfectly so i have no idea what it is.. Heres a picture to give a better idea, Any help would be appreciated!!