Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About Danny1565

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    5001 to 10,000
  • Interests
    Road Trips
    Food & Drink
    Computers & Electronics
  1. Hi there i own a fiesta 53 plate with 83000 miles on the clock. i've had it for 3 years nearly and done about 20000 miles in it since i brought it. It has been very reliable passed every MOT. Its had 4 services in the past 3 years with some small problems, I.e brake pads, wheel bearings, new tyres and coil pack. All just the general wear and tear stuff in older cars. Good Luck
  2. Hi.. I own a late 2003 Ford Fiesta z tec model which I have owned this car for nearly 3 years. It has 83000 miles on the clock and has being a very good reliable car with hardly any major problems until now. About over a month ago i started up the car and the ECA fail messaged appeared in the clock and millage display, also the revs were jumping up and down between 1000 -1500 which you could hear. I switched it off the engine and turned it on again and it solved the problem and have forgotten about it since today. Today, however as the car was in monition the accelerator wouldn't respond as it was going up a hill, it eventually came to a stop and i noticed that the E C A fail was displaying again, with the revs jumping up and down. Again i switched it off and on again and it solved the problem. Before i started the journey the car took three attempts to starts, so wondered if it was connected. The car had a major service at Ford about a month ago and it all looked ok. I don't want to leave it now and was wondering if anyone else has recently experience this before, I have read other forums on other websites from 2008 -2010,it sounds like a nightmare, but they are old so i am hoping that by now that this problem is more easier to fix than before as it seems common in these fiestas. If anyone has recently had this problem before and could give some advice on what the fault is and the cost i would be very grateful. thank you