Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Si G

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About Si G

  • Rank
    Newbie

Profile Information

  • Ford Model Focus
  1. Thanks for your replies Guys. Garage fixed it today, and looks like I was quite lucky. The timing belt was starting to shred and had shifted 2 teeth. Hence the car would Idle fine but under load the loss of power. Lucky not because it was cheap; it wasn't at £460 (including the service), but because of the fact I had discovered it seemed to run better at high revs, such as getting up to 70mph in 3rd
  2. My Ford Focus 1.8 Zetec (2002) has lost power and has poor acceleration. Came on suddenly, felt like hitting a pot hole. Engine now starts poorly, have to crank it with foot to floor(almost like it's flooded), but once started idle and reving engine okay. 1st and 2nd gear acceleration okay then feels sluggish, struggles to get upto 60mph. Though acceleration better (but still not right) if revs kept above 3000rpm. No engine fault codes, emmisions test passes. My local garage carried out a 75000mile service thinking that might clear the fault, they've checked compression, cleaned the throttle assembly, and pugged it into their diagnostic machine but no fault codes. Any ideas?