Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


digital_gee

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About digital_gee

  • Rank
    Newbie

Contact Methods

  • First Name Gee

Profile Information

  • Ford Model focus
  • Ford Year 2010
  • UK/Ireland Location Berkshire
  • Annual Mileage 0 to 5000
  1. Airbag And Seatbelt Warning Light

    turned out to be the SRS/Airbag module that failed... there goes £460 :(
  2. Airbag And Seatbelt Warning Light

    thanks for that, is there any guides for getting to these areas to check them?
  3. Hi all I've been searching deep corners of the internet and have had no luck for this issue. 10 plate focus 1.6 zetec (100) I was driving along one day no problems and have had no problems at all before. dropped of my mate at his house and grabbed something out of my boot at the same time, then pulled off and about 20 yards later both the airbag and seatbelt warning light came on... over the next 2-4 days it was intermittent, then it became permanent for the last 2 weeks to date. When intermittent it sometimes was not on at all, other times it came on part way through the (short) journey, or it was on straight away and turning the engine off then back on didn't get rid of it. I did the ford built in diagnostics check I've borrowed one of my mates cheap as chips bluetooth OBD readerand found these codes:- ObdU1900 - CAN Communication Bus FaultU2023 Abnormal message from PCMFord onboard test:Dtc #01 D900 I tried to reset them but couldn't. the only other thing I have tried is disconnecting the battery for the car for about an hour or so (turning it off the on again idea) does anyone know what it could be? I would like to repair it myself (I'm great with repairing electronic side of things, it's part of my job). Cheers, Gee.