AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


stuartadair

Budding Enthusiast
  • Content count

    9
  • Joined

  • Last visited

About stuartadair

  • Rank
    Newbie

Profile Information

  • Ford Model Fusion
  1. Fiesta P Reg Idle Speed

    Yeh but even if it was a timing issue you wouldnt take it to a garage to sort. Get your hands dirty and do it yourself :P
  2. Fiesta P Reg Idle Speed

    Sorted now. One of the vacuum pipes on the throttle housing had a blanking plug on and on the new engine I'd missed this off. Running sweet now, but has an overheating issue which is the subject of a new post
  3. Hello all P Reg Fiesta 1.25 just put a replacement engine in. Engine runs well however it doesnt appear that water is circulating as it should. Symptoms: Engine temperature reads normal/high. Both heater hoses hot where they go into the heater control on the bulkhead although heater is blowing cold air. Top and Bottom hoses, radiator both cold. I've removed the thermostat housing and all appears to be ok. Blown through as many pipes as I can and all seems to be flowing. I can feel the back of the water pump through the thermostat housing space and the rotor feels ok, its turning with the pulley. 2 theories so far that I would like your opinion about... a) The new engine originally had a power steering pump, old engine did not. I took the pump off and used the old belt. Could I have buggered up the belt routing so that the water pump is turning the wrong way? Its currently rotating anti-clockwise. Do the water pumps on non power steering cars rotate differently to power steering cars ? B) Heater control unit water connector collapsed as soon as I pulled the pipes off so I need to replace this. The r/h pipe has a control arm which appeared to be closed. Does this completely block the flow of water around the engine. Or perhaps something else I havent thought of... Anyway, sorry for the long post but I wanted to give you as much info as possible stu
  4. Fiesta P Reg Idle Speed

    Thanks Orcomma I'll check the pipes out. Hula89 was that a serious reply <_<
  5. Fiesta P Reg Idle Speed

    Hello all P reg Fiesta 1.25. Just changed the engine. Got the new one running tonight and it sounds really nice but the idle speed is too low. The engine sounds sweet on a little throttle but too low when you release the throttle. It got too dark to spend too much time on it tonight so I thought I'd come back and ask the experts where I should check next. Thanks in advance Stu
  6. Fusion locks but wont unlock

    Evening, If I pull the connector off on the drivers door A post and earth the black/red then the doors lock, and the black/white wires then the doors unlock just as they should. Using the key in either the driver or passengers door will lock the car ok but it wont unlock all the doors when you turn the key. As far as I can see there is only the 1 fuse running the central locking - Am I right ? Cheers Stu
  7. Fusion locks but wont unlock

    Plan B is I've got a generic central locking control unit off ebay. There are 6 control wires on the instructions For locking Orange - normally closed White - common Yellow - Normally open For unlocking Orange black - normally closed White - common Yellow black- Normally open Can anyone offer any ideas where to wire this in ? Stu
  8. Got a problem with a Fusion but as there are more Fiesta's about (And I'm sure the system is the same) Thought I'd duplicate the question here. 05 Plate Fusion. Central locking on key only. Central locking works fine for locking but not unlocking. No change on either front door. Dashboard switch not working for boot. When I earth black/red and black/white wires on drivers side door the system works fine - Help Please !!!
  9. Fusion locks but wont unlock

    05 Plate Fusion. Central locking on key only. Central locking works fine for locking but not unlocking. No change on either front door. Dashboard switch not working for boot. When I earth black/red and black/white wires on drivers side door the system works fine - Help Please !!!