Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


bungeeboy

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About bungeeboy

  • Rank
    Newbie

Profile Information

  • Ford Model
    fiesta
  1. so i cleaned the air idle control valve and it sorted out the initial problem, however as the guy above says around 3.5 - 4k rpm it stutters like its misfiring. its fine through the rest of the rev range so it must be a sensor type problem?
  2. Hi guys, Just got a pretty old P reg fiesta with a fair few miles on it but its gonna do the job for me. Just have a couple of issues that i need to get sorted but im not sure where to start. 1) when i start up the car seems to idle too high for few minutes at 1500rpm then it will drop to about 1000. When i pull away it stutters quite badly for about 1 minute then it seems ok. It tends to rev up a bit on gear change and runs away a little when the clutch is re-engaged. When i release the accelerator it seems to maintain speed for about 5 seconds. If i give it the beans at any point it splutters for a few secs then picks up and is ok. It will do this in all gears and does it a lot at 70mph. i have to ease off a little and then come back on the power slowly and its ok again for a while. 2) heater motor only blows on full - new resistor pack im guessing. in the passenger side footwell? 3) heater only blows cold 4) rear screen de-mist doesnt work other than relatively minor problems i think i got a pretty good deal at £200 Any help is appreciated. thanks