• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


tommyvb

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About tommyvb

  • Rank
    Newbie

Profile Information

  • Ford Model
    Focus Zetec 1.8
  1. Focus Dash Problem

    Thanks for your advice aswell mate. So what you recon should be done. i know your saying a new speed sensor. would that be around near the wheels to monitor the speed of the wheels and give you your speed on your dash, what ya think about the cutting out issue
  2. Focus Dash Problem

    Hello mate, Ahhh thanks for that advice, so you recon it could be a new battery needed.. When i say it cuts out i mean like when slowiing down to junctions and roundabouts it cuts out, and has to be restarted. i made sure its not my Girlfriend stalling lol its the car.. so what else do you recon
  3. Focus Dash Problem

    Hello all, My girlfriend has a focus on a 1999 plate i think its a 1.8 zetec and she has a problem with her speedo, now and again it wont work, she'll be drivign but no speedo working, this also leads to the car stalling/engine cutout when slowing down at junctions/round abouts etc etc ... she had it in garage a few times an the mechanics rather say its sorted or theres nothing wrong. But this only happens a few times, when the speedos not working she re-starts the car and most of the time it will work. i personally think there maybe a loose connection behind the dash or a mucky/corroded connection. thats why it wont be working 100% but with the car cutting out that baffels me lol. so thats why i come on here and ask if anyone knows anything about this problem and could help me.. Many Thanks and if anyone knows anythings please reply or email me and let me know. all information is very very much appricated .. thanks