Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Jaynie91

Budding Enthusiast
  • Content count

    10
  • Joined

  • Last visited

About Jaynie91

  • Rank
    Member

Contact Methods

  • First Name
    Jayne

Profile Information

  • Ford Model
    Fiesta
  • Ford Year
    1999
  • UK/Ireland Location
    Cambridgeshire
  • Annual Mileage
    0 to 5000
  • Interests
    Food & Drink
    Entertainment
    Arts & Crafts
  1. How would we go about putting it in with a g clamp? Just want to be sure to get them in as quick as and dont want.to do it wrong and cause damage. Thank
  2. So you know, after cutting through it, we managed to remove it without remoing the rubber, it must have loosened the sleeve enough as after our method of the screwdriver and the hammer, it started to slide out with every hit, rather than the other side where it shot out. Now just the fund part of getting the new ones in :) (and everything else for the MOT, the joys :) )
  3. Yes, there is a metal sleeve is you mean the part that the rubber attaches to, it seems to be that badly seized you can hardly tell what is the car and what is the bush
  4. Yes, this.photo.is from under the car, it is raised up. By the way, the one missing the centre.we have managed to get out not, i had to cut it with the hacksaw, then with a hammer and large screwdriver, prise it from underneath to bend it then it.suddenly.shot.out.whilst hitting it
  5. This is the drivers side, the passenger side doesn't have anything in the middle now, the rubber has come out.
  6. Hello, Just a quick question if anyone has any ideas, we are trying to replace the trailing arm bushes on my 1999 Fiesta however it would seem that nothing has been changed on my car since it came out the showroom as most things take a lot of brute force to get out. We don't have a bush puller or whatever it is called and going by the Haynes guide has helped us get to the stage of taking out the bushes but it would appear that one bolt had seized, which we have managed to get out to drop the axel, however now the bushes appear to be seized in the axel. Any ideas how we can get them out? I have seen one step by step online with seized ones where they used a hacksaw to cut through everything then used the bush puller to pull the bush out, however we do not have one and they appear to be really stuck in there, so really any ideas on how to get them out, I have managed to cut nearly through one of them but with another one to go, any advise would be great. Thanks Jaynie
  7. My friend has got a Ford KA, 2003, which the engine management light is on and the car is juddering as soon as the engine is turned on. They have changed the spark plugs and coil pack as per recommendation from a garage however it still has the problem. The HT leads haven't been changed however they are still sparking. Has anyone else had this problem? Thanks Jayne
  8. Sorry for late reply, but thanks as it was the fuse, I can only assume as we checked them before that it blew after we sorted out the indicators. Thanks Jayne
  9. Sorry, what i meant was we tested the horn in the car by pressing the middle of the steering wheel and it didnt work, however my father in law tested the horn itself under the bonnet and it worked so its not a fault with the horn itself
  10. Hello, I have a T Reg/1999 Ford Fiesta Mk VI. I needed a new headlight and so we got one from a scrapyard to replace the one I had, which had to be changed due to my partner hitting a pheasant and it broke part of the plastic housing and was held in by 1 screw. We had replaced the passenger one from a scrapyard one before and know how to change one however as we went to replace it, I was checking the lights and the indicator started clicking a lot then suddenly stopped, no indicators, no clicking, no hazards. We have checked the fuses and the one for the indicators had blown, so we changed it and to begin with had no luck. We then changed the flasher unit on the steering column and seem to have the indicators working but the hazard lights wont work and neither will the horn, which I have the understanding that they work off the same switch. We have checked the fuses again, all of the ones in the engine and by the steering wheel, we have checked and changed the relays and even tried another hazard light switch from another fiesta but it doesn't seem to work. The horn still works as we have tested this but we don't know what could be causing the hazards to not work. We have also been looking in the Haynes manual and found they are both off the multifunction switch. Any ideas or help would be great. Thanks Jayne