Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About howey90

  • Rank

Recent Profile Visitors

364 profile views
  1. Hi guys i have a focus 1.6 petrol duretech and it has a fault i cant figure out when i accelerate it sum times feels like im getting pulled bk and then i can only touch the throttle bout a inch after an inch it loses all power but once left for 20min it will be sort of ok but still sort of misses when putting my foot down i have changed oil and filter air filter fuel filter coil pack lambda I was told it might of been the fuel filter then i was told the cat was blocked and it causing back pressure but i unscrewd the pre cat lambda and still doing the same thing also tryed redx and no luck any of you guys got any ideas ps. Duretech has no maf sensor or egr and there is no engine m light or old codes Sent from my iPhone using Ford OC
  2. Hi all i have a 1.6 petrol mk1 focus elle and to day out the blue went in limp mode turnd it of was ok then back in about 3 time i came straight home plugged it in and only code was 02 sensor (after cat) so i cleared it and its ok for now any of you guys ever herd of a o2 sensor causing this course i haven't got me puzzled ? Sent from my iPhone using Ford OC
  3. Yep was a cheap fix but if its done it once it will do it again so ill keep euro in mind thanx for that info Sent from my iPhone using Ford OC
  4. Its ok now found it was the motor seized so removed it and wd and copper slip sorted it out good as new now And thank for taking the time reply Sent from my iPhone using Ford OC
  5. Im geting 12v to the switch but as soon as i turn the heater on it pops the fuse is there any way to test the switch with a multimeter? Sent from my iPhone using Ford OC
  6. Hi guys i have a focus with a 6000 cd player in it but the fingertip steering wheel changer wont work so i pulled the cd player out and there is 3 plugs on the harness but only 2 and a little one on the cd player car is a 03 focus elle any one no the correct cd player for this car? Sent from my iPhone using Ford OC
  7. The Fuse keeps blowing aswell Sent from my iPhone using Ford OC
  8. Hi new on hear i have just purchased a focus elle 03 to day and the heaters not working or a/c button not lighting up and the cluster on the steering wheel to change vol isnt ithere i have changed the fuse but no luck any one have any ideas ? Sent from my iPhone using Ford OC