Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Arrow

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About Arrow

  • Rank
    Newbie

Contact Methods

  • First Name Rick

Profile Information

  • Ford Model Ka 1.3 Endura-E
  • Ford Year 1996
  • UK/Ireland Location Other/NonUK
  • Annual Mileage 0 to 5000
  1. Hi Everyone

    Hi guys (and girls!) I'm Arrow and I currently drive a 1996 Ford Ka 1.3 First Edition. I've had a Seat Ibiza 1.4 (also from 1996) before but that car broke down almost every 100 yards. So, I ditched it, saved some money and bought myself a 1996 Ka. Lovely car, very few problems so far. If there's anything else you'd like to know, don't hesitate to ask!
  2. Hi there! When I started my 1996 Ford Ka 1.3 Endura e last morning the engine made a strange ticking noise. The noise appeared when I started the engine, during low gears and when I depressed the clutch in high gears or when I took my foot off the throttle. Several people on the internet indicated it could be one of the tappets, but the sound doesn't get any faster/louder when I accellerate and it sounds nothing like the sound in this video I'm not too familiar with car mechanics so I'm hoping one of you is able to provide me with a possible explanation or fix for the problem, as I don't want to waste a couple hundred of euros on a garage if it's something I can fix myself with a spanner. Thanks in advance!