Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About ozzbozz

  • Rank

Profile Information

  • Ford Model
    Mondeo 2.0 TDI (MK IV)
  1. Hi, I have a 57 plate Mondeo 2.0 TDi (Mark IV), from June last year, ex demonstrator from Arnold Clark. Anyway to the problem, which has happened about 3 times now over the past month, I was driving into Town picked up mother from the shops and on my way back the car slowed to a crawl mainly because the engine was limiting the revs. At the same time on the Electronic display on the dash the following error message appeared "Engine Malfunction." After a little bit of crawling I parked up turned off the engine waited a while turned it back on and hey presto the car was fine and even the display said no messages as if nothing had happened, so I just left it. However the next time it happened I was entering a round about and the shock almost made me head towards the island so anyway booked it into me local Clarkys where I bought it. Guess what they could find nothing wrong with it after putting it on the computers twice and doing a manual check. I even suggested they drive it but still they could not fault it, so reluctantly I just had to take it back, knowing there is something there lurking away. So after all that spiel I'm wondering A; Has it happened to anyone else? and B; Do they have any clue what it could be? Btw apart from this the car drives like a dream. Thanks in advance guys. ;)
  2. Huge, Trust me after driving a number of Volvo's over the years thats all you need to know ;)