gary12345

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About gary12345

  • Rank
    Newbie

Contact Methods

  • First Name
    gary

Profile Information

  • Ford Model
    galaxy
  • Ford Year
    2001
  • UK/Ireland Location
    Gloucestershire
  • Annual Mileage
    5001 to 10,000
  1. That's brilliant I will put on the ramps and have a look. Many thanks for your help Sent from my iPhone using Ford OC
  2. Does the galaxy 1.9tdi 2001 have a speed sensor on the gear box or is the speedo driven via the front abs. If there is a sensor on the gear box does anyone know the location and have a picture to show it please and how easy is it to change Thanks for the input in advance Sent from my iPhone using Ford OC
  3. Evening all As I can't find a answer to try and sort my old speedo out I have another question to all you peeps. I have a 2001 1.9tdi galaxy and have put a 03-04. Model speedo in but reads grater on speedo e.g when doing 70mph speedo reads 110mph. Sure they changed the cluster on the 03 models onwards. Am I able to take it anywhere or buy the software to correct the speedo reading. Thanks in advance Sent from my iPhone using Ford OC
  4. Evening all I have a ford galaxy 1.9tdi on a 2001 The speedo has stopped working and the fuel gauge goes up and down when driving. Fuel gauge show correct when still For them both to go at the same time I'm looking at a wiring fault I have read forums with people with the same problem but can't find anything that has fixed the fault Things that I have done is changed the speedo from a 03 model and the speedo and fuel gauge works fine apart from speedo does not give a true reading as I believe they change the cluster on this year. So I bought another from the same year (2001)and that does the same. Fuel gauge goes up and down and speedo not working. I know the fuel gauge and speedo are not at fault. I have also disconnected the battery for 24hrs. There is no corrosion on the wiring on the 2 blocks that plug into the speedo. Can't under stand how the 03 model speedo works but the earlier model does not Can anyone shed some light on what the fault could be. Many thanks in advance Sent from my iPhone using Ford OC
  5. please help, I have a galxay 1.9tdi 2001 with 118000 miles the car has devoloped a fault which i'm sure most have seen but i can't find anyone that has found the cure. here goes: The speedo has stopped working and when you start driving the fuel gauage goes up and down. things that i have done are: replaced the speedo with a 03 model which works fine but runs MPH to fast, so i bought another second hand one which came off another 2001 model and have the problem, so i'm gussesing that my clocks are fine. i have checked the wiring that goes in to the clocks and they are all free from corresion, also done a wiggle test on them. As the 03 clocks work i know its not a fault with the speedo sensor or fuel sensor as work fine with those clocks it just reads wrong MPH e.g when i do 70 it shows 110mph Has anyone else had this problem or know how to fix, driving me up the wall now Many thanks in advance
  6. Welcome to the Ford forums gary12345 :)

    If you get stuck on how to post a question on the forums or trying to message a member then check out our video guides to help you get started!

    http://www.fordownersclub.com/forums/forum-0/announcement-47-how-to-use-our-forum-video-guides/