Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


winnebago13

New Member
  • Content count

    1
  • Joined

  • Last visited

About winnebago13

  • Rank
    Newbie

Contact Methods

  • First Name Sean

Profile Information

  • Ford Model Fiesta
  • Ford Year 2008
  • UK/Ireland Location London
  • Annual Mileage 5001 to 10,000
  1. Hi Got a 2008 Ford Fiesta Zetec 1.4 TDCi Diesel, 50,000 miles generally in good nick. Its been suffering from a stutter in acceleration over the last 12 months. On the motorway the other day it just lost power and we had to pull over. Eventually we got it started again but a couple hundred miles later it conked out again and this time it had to be towed home as it shifted to limp mode. I took it to a garage over a week ago and they said that the wiring on the loom had come loose and had melted on the engine causing a short. So far they have replaced the injector loom in full and replaced the inlet manifold seals. However, the car remains in limp mode. The garage are now saying the ECU will need replacing as the "short has spread" to it. I have very limited knowledge of engines and don't know if what they are saying is correct. Any ideas? Cheers Sean
  2. Welcome to the Ford forums winnebago13 :)

    If you get stuck on how to post a question on the forums or trying to message a member then check out our video guides to help you get started!

    http://www.fordownersclub.com/forums/forum-0/announcement-47-how-to-use-our-forum-video-guides/