Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


firstmark326

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About firstmark326

  • Rank
    Newbie

Contact Methods

  • First Name Mark

Profile Information

  • Ford Model Mondeo
  • Ford Year 2002
  • UK/Ireland Location Surrey
  • Annual Mileage 0 to 5000
  1. I have recently noticed a metalic noise from the rear when going over speed bumps seems to be more when people are in the back, did have a new brake caliper fitted a few weeks ago and guy said heat sheild was loose and pinned it back for me. Had a look under car and cannot see anything, there is a little bit of play in exhaust from side to side but nothing major. No noise when the front of car goes over anything just the back. Any ideas?
  2. Hi just wondering if anyone can offer any ideas as to why the oil light is not working on my 2002 mondeo, bought it a few months ago with no oil light working then all of a sudden when turning the engine over I noticed the oil light flikering then after that it was working as normal and going off when engine was started. Now the oil light has stopped working again, could it be anything on the engine end?
  3. Cambelt Or Chain

    Hi thanks, had a look on google and although there is a belt linking the water pump and such on the side underneath its a chain
  4. Cambelt Or Chain

    Hi recently bought a 2002 mondeo, can anyone tell me if it's a cambelt or a chain on this model. Its a 1.8 petrol
  5. Hi just bought a 2002 mondeo a few weeks ago and noticed that the oil light no longer works on the dash, I've tried the self diagnostic test and the light still doesn't work so i'm thinking a blown bulb. Does anyone know if it could be a loose cable or plug on the engine near the pump if not what am i looking at to get replaced? Many thanks
  6. Welcome to the Ford forums firstmark326 :)

    If you get stuck on how to post a question on the forums or trying to message a member then check out our video guides to help you get started!

    http://www.fordownersclub.com/forums/forum-0/announcement-47-how-to-use-our-forum-video-guides/