• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


madboymatt

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About madboymatt

  • Rank
    Newbie

Contact Methods

  • First Name
    matt

Profile Information

  • Ford Model
    Fusion SEL V6
  • Ford Year
    2010
  • UK/Ireland Location
    Other/NonUK
  1. Instrument Cluster Backlight Stays On

    So I could pick one up at a junk yard or online, then just have the dealership calibrate the mileage etc?
  2. Instrument Cluster Backlight Stays On

    Update: it went back to normal today. I noticed that one of the LEDs flickered and went out. So I think there is a short or a bad connection on the circuit board.
  3. Instrument Cluster Backlight Stays On

    If that is the case, what would be a good way to fix it? The reason I don't think its related to the ignition switch is because all the other lights go out.
  4. Hey guys. I have a 2010 SEL V6. So tonight I noticed that after I've turned the car off, removed the key, and locked the car, the instrument cluster backlight remains lit. Just the blue light stays on. I have read through the manual looking to see if I caused this to stay on with a setting or if I pressed something by accident. The only thing I can think of is that earlier today, I went to get something out of my car, and rather than using the key to unlock it, I used the keyless door code, and I had to try a few times becuase the code wasnt being recognized. So maybe I pressed a series of number that casued the light to stay on??? Super weird. Upon further investigation, I pulled fuse #26 for the "instrument cluster battery power" and the light went off. Swapped it for a spare fuse to be safe and the light came back on. So something is feeding that fuse power regardless. Or There is a short in the panel. I noticed that once of the LEDs is out. It won't light up while the rest of the board is lit. Also, while the car is on, I can't dim the backlight at all. The other dash and radio lights will dim, but not the backlight. Not sure where to go from here, and was hoping someone had an idea of what is keeping it on. Thanks very much.