Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About johnnyp

  • Rank

Profile Information

  • Ford Model
    focus lx 2006
  1. Hello All, Further to my last, car still running OK. Worth the time cleaning / adjusting. GOOD LUCK johnnyp
  2. Hello All, Further to my last - for info, ICV/throttle body off again, battery disconected also. On reassembly I adjusted a sping damper fitted below throttle valve actuator, this cannot be seen in situ' . with a cut 1/8 th w spanner it can be fine tuned in situ' (now we know its there) Took me a while to fine tune, very small turns is all req'd , adjust- take run - adjust - take run, BUT, it seems to have worked. Pedal switch was a red herring I think. I will keep you posted, and my fingers crossed!! GOOD LUCK johhnyp
  3. Hello All, Cleaned throttle body, bit oily, restarted ok ran for a while then raced up + down 1500 ish. fault code was throttle position idle not learned. starts ok , can hold at about 1000 rpm on foot but will not hold tickover. How can I get ECU to relearn tickover?? THANKS johnnyp
  4. Hello All, Thanks Mintalkin, yes, I think I will start at icv. Looks a bit arkward seems to be encased in throttle housing, but needs must! At moment, I have disconected clutch pedal switch, locked in engaged position,it hasn't cut out in 4 days! Throttle occasionally drops to about 600 no stall so far. The best thing is it keeps wife off my back!!! Keep you posted THANKS, GOOD LUCK johnnyp
  5. Hello All, Car cuts out at times, slowing down for turns/roundabouts ect. No codes shown. Engine speed drops but doesnt pick up again. Had seen topics ref' speed sensor at gear box, this model does not have this sensor, I assume it works off abs system? Is it worth strip/clean ICV or air flow sensor? Cant find anything on this model anywhere! THANKS Johnnyp