Members via FB
  • Content count

  • Joined

  • Last visited

About pauld2411

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    5001 to 10,000
  • Interests
    General Automotive
    Road Trips
    Computers & Electronics
  1. Is this all of the time or intermittent , do you at any time go into limp mode
  2. My injector 2 is faulty , anyone with the same symptoms you will know what is wrong
  3. Thanks for the update might not be as rare as ford might let on as I have the exact same symptoms I previously had it into ford who found a slight anomaly with injector 3 but then only remapped the injectors
  4. Thanks for the update might not be as rare as ford might let on as I have the exact same symptoms I previously had it into ford who found a slight anomaly with injector 3 but then only remapped the injectors
  5. I have the same issue on the same model of Mondeo , I have a 2009 with 40k on the clock intermittent and get limp mode twice a year but hesitation nearly every week , if this is camshaft sensor I will change first to see as they are only about 20 quid I thought it was more like signs of injector failing , did you get the problem checked out?
  6. Hows it going , i have the same car,year and same issue , this would occur at motorway driving and then became more of a problem even during 30-40mph driving , i did a couple of things and for 5 months i have not had the same issue , do you have more smoke than normal also , fit a EGR blanking plate (£3 off ebay) , also change your air filter to a premium filter (non ford) and clean out the air inlet duct work , also check for holes in the turbo pipework such as intercooler to EGR to see if you have any wear in the pipework (only way to see underneath is the engine cover needs taken off ) sometimes though the hole is not seen unless your up around 2000RPM, one last thing is to check all your air inlet pipework is fully secured including going to EGR The fault doesnt even register on a fault reader they tried to tell me there was an issue with Injector 3 and they cleaned it out and remapped them , i still had the issue after it left them with them also telling me that with no fault code they dont know the fault problem just like yourself, i have my own reader and when the engine malfunction came on i plugged in my own reader and it didnt have any DTC's stored in the ECM
  7. Did you get this resolved , I had exactly the same issue today pulling out of a junction , car juddered and engine malfunction lit up along with traction control light , I have a fault reader but it states no fault was stored in the ECU so don't know what the issue is , any thoughts
  8. Mileage is 36000
  9. Hi all , im getting only about 37 MPG and get some black smoke at 2000 RPM and smoky on start up , i blanked off the EGR thinking it would help but i still get a smoky Mondeo and the smell is bad (like following an old transit van), to me its a air or fuel mix problem , there is slight loss of power daily for a second or 2 when you are driving , Ford previously couldnt find a problem and couldnt fidn the fault , i have had 2 engine malfunction amber lights in the last year with the loss of power but didnt have my OBD2 to read the fault each time , without a fault code not sure of the problem , could this be either a turbo hose problem , i cant see anything wrong with the hose , or could this be the MAF sensor or other June 2009 MK4 TDCI Mondeo
  10. Ok , so I bought the blanking plate as recommended , everything for the last month has been ok but I haven't done any motorway driving so lower speeds , I thought the hesitation had disappeared until today when the car started its "jerkiness" at approx. 45mph to rectify I slowed down and the problem disappeared again , could this still be an EGR sticking or could there be a split in a hose somewhere , there is slight black soot deposits on the side of the EGR where the inlet hose connects to it , this is fitted tight , there are also amounts of black smoke on heavy acceleration but not any other time , is this an air intake problem rather than EGR ?
  11. Thanks all for the responses much appreciated , one last question does your engine management light ever come on since you used a fully blanked plate?
  12. Is the plate normally blank , I have seen some with a hole in the centre ?
  13. Hi im new to this forum , I have owned fords for over 10 years , first ford was a focus now I drive a MK4 Mondeo but currently having problems as per another post , hoping to get ideas and support , thank you
  14. Hi im new to this site but im looking some help or if anyone else has got the same problem , since buying my Mondeo MK4 I have reported back to the local ford dealer about hesitation particurly in the 70mph region , I left the car in and they updated the software , last year I was out 50 miles from home and the car was doing random hesitation then on acceleration into a dual carriageway the amber engine failure light came on and it felt the car lost power , I got it recovered to the local dealer who said initially they couldn't find a problem but then told me they found a code on injector 2 but it seemed still to be in spec , they informed me they cleaned the rail and then remapped the injectors , this was August last year , the car since then would do the random hesitation but not as much then today on the motorway started doing it again and then the amber engine failure light came on , I have an OBD11 and it didn't read any fault codes on the computer , im a member of the AA and got them out to see if their fault reader picked anything up but theirs also had no fault codes , I proceeded to drive the car back home at 50 mph the full journey and didn't get the hesitation at all (bar 1 slight kick at a set of traffic lights) , anyone any ideas , could this be the EGR needing cleaned or could it be an injector , any help would be appreciated 2009 Mondeo TDCI 1.8
  15. Welcome to the Ford forums pauld2411 :)

    If you get stuck on how to post a question on the forums or trying to message a member then check out our video guides to help you get started!